connectivity_plus 1.1.0
connectivity_plus: ^1.1.0 copied to clipboard

Flutter plugin for discovering the state of the network (WiFi & mobile/cellular) connectivity on Android and iOS.

408
likes
130/ 130
pub points
99%
popularity

We analyzed this package on Sep 16, 2021, and awarded it 130 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 4 out of 5 API elements (80.0 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support Flutter platform `Android`.

Because:

  • package:connectivity_plus/connectivity_plus.dart that imports:
  • package:connectivity_plus_linux/connectivity_plus_linux.dart that declares support for platforms: Linux.
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
connectivity_plus_linux^1.1.01.1.01.1.0
connectivity_plus_macos^1.1.01.1.01.1.0
connectivity_plus_platform_interface^1.1.01.1.01.1.0
connectivity_plus_web^1.1.01.1.0+11.1.0+1
connectivity_plus_windows^1.1.01.1.01.1.0
flutterflutter0.0.00.0.0
meta^1.3.01.3.01.7.0
Transitive dependencies
PackageConstraintCompatibleLatest
args-2.3.02.3.0
characters-1.1.01.2.0
collection-1.15.01.15.0
dbus-0.5.60.6.3
ffi-1.1.21.1.2
flutter_web_plugins-0.0.00.0.0
js-0.6.30.6.3
nm-0.3.00.4.0
petitparser-4.1.04.3.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0
xml-5.1.25.3.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.20.0, Flutter 2.2.3, Dart 2.13.4.