cmw_remote_data 0.0.8 copy "cmw_remote_data: ^0.0.8" to clipboard
cmw_remote_data: ^0.0.8 copied to clipboard

A new Flutter package project.

0
likes
90/ 140
pub points
0%
popularity

We analyzed this package 4 days ago, and awarded it 90 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

* `pubspec.yaml` doesn't have a `homepage` entry. * `pubspec.yaml` doesn't have a `repository` entry.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

6 out of 56 API elements (10.7 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: cmw_remote_data, cmw_remote_data.ApiError, cmw_remote_data.ApiError.ApiError, cmw_remote_data.ApiError.exception, cmw_remote_data.ApiError.onRetry.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

lib/src/api_exception.dart doesn't match the Dart formatter.

To format your files run: dart format .

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
collection ^1.15.0 1.18.0 1.18.0
flutter flutter 0.0.0 0.0.0
flutter_hooks ^0.18.2 0.18.6 0.20.5
flutter_riverpod ^1.0.3 1.0.4 2.4.10
hooks_riverpod ^1.0.3 1.0.4 2.4.10
infinite_scroll_pagination ^3.1.0 3.2.0 4.0.0
json_annotation ^4.4.0 4.8.1 4.8.1
rxdart ^0.27.3 0.27.7 0.27.7
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
riverpod - 1.0.3 2.5.0
sky_engine - 0.0.99 0.0.99
sliver_tools - 0.2.12 0.2.12
state_notifier - 0.7.2+1 1.0.0
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `^0.18.2` on flutter_hooks does not support the stable version `0.19.0`.

Try running dart pub upgrade --major-versions flutter_hooks to update the constraint.

The constraint `^1.0.3` on flutter_riverpod does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions flutter_riverpod to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.1, Dart 3.3.0.

Check the analysis log for details.

0
likes
90
pub points
0%
popularity

Publisher

unverified uploader

A new Flutter package project.

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

collection, flutter, flutter_hooks, flutter_riverpod, hooks_riverpod, infinite_scroll_pagination, json_annotation, rxdart

More

Packages that depend on cmw_remote_data