cloudbase_core 0.0.11
cloudbase_core: ^0.0.11 copied to clipboard

Flutter plugin for cloudbase core.

4
likes
55/ 130
pub points
65%
popularity

We analyzed this package on Oct 28, 2021, and awarded it 55 pub points (of a possible 130):

Follow Dart file conventions
5 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

`CHANGELOG.md` contains too many non-ASCII characters.

The site uses English as its primary language. The content of CHANGELOG.md in your package should primarily contain characters used in English.

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 25 out of 82 API elements (30.5 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:cloudbase_core/cloudbase_core.dart that imports:
  • package:cloudbase_core/src/store.dart that imports:
  • package:shared_preferences/shared_preferences.dart that imports:
  • package:shared_preferences_windows/shared_preferences_windows.dart that declares support for platforms: Windows.
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/cloudbase_core.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/src/trace.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
crypto^2.1.32.1.53.0.1
dio^3.0.73.0.104.0.1
flutterflutter0.0.00.0.0
package_info^0.4.0+170.4.3+42.0.2
shared_preferences^0.5.60.5.12+42.0.8
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.2.0
charcode-1.3.11.3.1
collection-1.15.01.15.0
convert-2.1.13.0.1
ffi-1.1.21.1.2
file-6.1.26.1.2
flutter_web_plugins-0.0.00.0.0
http_parser-3.1.44.0.0
js-0.6.30.6.3
meta-1.7.01.7.0
path-1.8.01.8.0
path_provider_linux-0.0.1+22.1.0
path_provider_platform_interface-1.0.42.0.1
path_provider_windows-0.0.52.0.3
platform-3.0.23.0.2
plugin_platform_interface-1.0.32.0.2
process-4.2.44.2.4
shared_preferences_linux-0.0.2+42.0.2
shared_preferences_macos-0.0.1+112.0.2
shared_preferences_platform_interface-1.0.42.0.0
shared_preferences_web-0.1.2+72.0.2
shared_preferences_windows-0.0.2+32.0.2
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1
win32-2.2.102.2.10
xdg_directories-0.1.20.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `^2.1.3` on crypto does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions crypto to update the constraint.

The constraint `^3.0.7` on dio does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions dio to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.1.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.3, Flutter 2.5.3, Dart 2.14.4.

4
likes
55
pub points
65%
popularity

Publisher

cloudbase.net

Flutter plugin for cloudbase core.

Homepage

Documentation

API reference

License

unknown (LICENSE)

Dependencies

crypto, dio, flutter, package_info, shared_preferences

More

Packages that depend on cloudbase_core