cloudbase_core 0.0.9

  • Readme
  • Changelog
  • Installing
  • 72

Cloudbase Core for Flutter #

Pub

腾讯云·云开发的 Flutter 插件,更多的云开发 Flutter 插件请见云开发文档

安装 #

在 flutter 项目的 pubspec.yaml 文件的 dependencies 中添加

dependencies:
  cloudbase_core: ^0.0.4

简单示例 #

import 'package:cloudbase_core/cloudbase_core.dart';

// 初始化 CloudBase
CloudBaseCore core = CloudBaseCore.init({
    // 填写你的云开发 env
    'env': 'your-env-id'
});

详细文档 #

云开发·初始化

[0.0.9] - 2020.06.04 #

  • 修复数据库和移动安全来源校验的协议版本号冲突的问题

[0.0.8] - 2020.05.19 #

  • 升级数据协议版本号

[0.0.7] - 2020.05.14 #

  • 支持移动安全来源校验
  • 支持用户统计分析

[0.0.6] - 2020.05.07 #

  • http request 接口支持返回进度

[0.0.5] - 2020.04.22 #

  • 修复登录态的bug

[0.0.4] - 2020.04.07 #

  • 优化 readme

[0.0.3] - 2020.03.12 #

  • 修正数据库版本号

[0.0.2] - 2020.02.10 #

  • 修改envId参数为env
  • 添加异常码

[0.0.1] - 2020.01.14 #

  • 核心库

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  cloudbase_core: ^0.0.9

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:cloudbase_core/cloudbase_core.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
60
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
60
Overall:
Weighted score of the above. [more]
72
Learn more about scoring.

We analyzed this package on Jul 11, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.15
  • Flutter: 1.17.5

Analysis suggestions

Package does not support Flutter platform Android

Because:

  • package:cloudbase_core/cloudbase_core.dart that imports:
  • package:cloudbase_core/src/store.dart that imports:
  • package:shared_preferences/shared_preferences.dart that imports:
  • package:shared_preferences_linux/shared_preferences_linux.dart that declares support for platforms: Linux

Package does not support Flutter platform Linux

Because:

  • package:cloudbase_core/cloudbase_core.dart that imports:
  • package:cloudbase_core/src/request.dart that imports:
  • package:cloudbase_core/src/sign.dart that imports:
  • package:package_info/package_info.dart that declares support for platforms: Android, iOS, macOS

Package does not support Flutter platform Web

Because:

  • package:cloudbase_core/cloudbase_core.dart that imports:
  • package:cloudbase_core/src/store.dart that imports:
  • package:shared_preferences/shared_preferences.dart that imports:
  • package:shared_preferences_linux/shared_preferences_linux.dart that declares support for platforms: Linux

Package does not support Flutter platform Windows

Because:

  • package:cloudbase_core/cloudbase_core.dart that imports:
  • package:cloudbase_core/src/store.dart that imports:
  • package:shared_preferences/shared_preferences.dart that declares support for platforms: Android, iOS, Linux, macOS, Web

Package does not support Flutter platform iOS

Because:

  • package:cloudbase_core/cloudbase_core.dart that imports:
  • package:cloudbase_core/src/store.dart that imports:
  • package:shared_preferences/shared_preferences.dart that imports:
  • package:shared_preferences_linux/shared_preferences_linux.dart that declares support for platforms: Linux

Package does not support Flutter platform macOS

Because:

  • package:cloudbase_core/cloudbase_core.dart that imports:
  • package:cloudbase_core/src/store.dart that imports:
  • package:shared_preferences/shared_preferences.dart that imports:
  • package:shared_preferences_linux/shared_preferences_linux.dart that declares support for platforms: Linux

Package not compatible with SDK dart

Because:

  • cloudbase_core that is a package requiring null.

Health suggestions

Fix lib/src/base.dart. (-0.50 points)

Analysis of lib/src/base.dart reported 1 hint:

line 1 col 8: Unused import: 'package:cloudbase_core/src/trace.dart'.

Fix lib/src/sign.dart. (-0.50 points)

Analysis of lib/src/sign.dart reported 1 hint:

line 2 col 8: Unused import: 'dart:io'.

Format lib/cloudbase_core.dart.

Run flutter format to format lib/cloudbase_core.dart.

Fix additional 3 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/src/auth.dart (Run flutter format to format lib/src/auth.dart.)
  • lib/src/request.dart (Run flutter format to format lib/src/request.dart.)
  • lib/src/trace.dart (Run flutter format to format lib/src/trace.dart.)

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and cloudbase_core.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
crypto ^2.1.3 2.1.5
dio ^3.0.7 3.0.9
flutter 0.0.0
package_info ^0.4.0+17 0.4.1
shared_preferences ^0.5.6 0.5.8
Transitive dependencies
charcode 1.1.3
collection 1.14.12 1.14.13
convert 2.1.1
file 5.2.1
flutter_web_plugins 0.0.0
http_parser 3.1.4
intl 0.16.1
meta 1.1.8 1.2.2
path 1.7.0
path_provider_linux 0.0.1+2
path_provider_platform_interface 1.0.2
platform 2.2.1
plugin_platform_interface 1.0.2
process 3.0.13
shared_preferences_linux 0.0.2+1
shared_preferences_macos 0.0.1+10
shared_preferences_platform_interface 1.0.4
shared_preferences_web 0.1.2+7
sky_engine 0.0.99
source_span 1.7.0
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6 1.2.0
vector_math 2.0.8 2.1.0-nullsafety
xdg_directories 0.1.0
Dev dependencies
flutter_test