cloud_firestore_web 0.2.0-dev.1

Flutter web

The web implementation of cloud_firestore

13
likes
50 / 100
pub points
99 %
popularity

We analyzed this package on Oct 18, 2020, and awarded it 50 pub points (of a possible 100):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 10

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

Support multiple platforms
0 / 20

0/20 points: Supports 1 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package does not support Flutter platform Android

Because:

  • package:cloud_firestore_web/cloud_firestore_web.dart that declares support for platforms: Web
Package does not support Flutter platform iOS

Because:

  • package:cloud_firestore_web/cloud_firestore_web.dart that declares support for platforms: Web

Consider supporting these prerelease platforms:

Package does not support Flutter platform Windows

Because:

  • package:cloud_firestore_web/cloud_firestore_web.dart that declares support for platforms: Web
Package does not support Flutter platform Linux

Because:

  • package:cloud_firestore_web/cloud_firestore_web.dart that declares support for platforms: Web
Package does not support Flutter platform macOS

Because:

  • package:cloud_firestore_web/cloud_firestore_web.dart that declares support for platforms: Web
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
cloud_firestore_platform_interface>=2.0.0-dev.1 <2.1.02.0.12.1.2
firebase^7.3.07.3.27.3.2
firebase_core>=0.5.0-dev.1 <0.6.00.5.0+10.5.0+1
flutterflutter0.0.00.0.0
flutter_web_pluginsflutter0.0.00.0.0
http_parser^3.1.33.1.43.1.4
js^0.6.10.6.20.6.2
meta^1.1.71.3.0-nullsafety.31.3.0-nullsafety.4
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.31.1.0-nullsafety.3
charcode-1.1.31.2.0-nullsafety.1
collection-1.15.0-nullsafety.31.15.0-nullsafety.3
http-0.12.20.12.2
matcher-0.12.90.12.10-nullsafety.1
path-1.7.01.8.0-nullsafety.1
plugin_platform_interface-1.0.31.0.3
quiver-2.1.32.1.3
sky_engine-0.0.990.0.99
source_span-1.7.01.8.0-nullsafety.2
stack_trace-1.9.51.10.0-nullsafety.4
string_scanner-1.0.51.1.0-nullsafety.1
term_glyph-1.1.01.2.0-nullsafety.1
typed_data-1.3.0-nullsafety.31.3.0-nullsafety.3
vector_math-2.1.0-nullsafety.32.1.0-nullsafety.3

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `>=2.0.0-dev.1 <2.1.0` on cloud_firestore_platform_interface does not support the latest published version `2.1.2`

pubspec.yaml:22:39

   ╷
22 │   cloud_firestore_platform_interface: ">=2.0.0-dev.1 <2.1.0"
   │                                       ^^^^^^^^^^^^^^^^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs