cloud_firestore_web 0.1.0+4
cloud_firestore_web: ^0.1.0+4

The web implementation of cloud_firestore

15
likes
30 / 110
pub points
99 %
popularity

We analyzed this package on Nov 22, 2020, and awarded it 30 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 10 out of 12 API elements (83.3 %) have documentation comments.
Support multiple platforms
0 / 20

0/20 points: Supports 1 of 3 possible platforms (iOS, Android, Web)

Found 7 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Android

Because:

  • package:cloud_firestore_web/cloud_firestore_web.dart that declares support for platforms: Web
Pass static analysis
0 / 30

0/30 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

ERROR: 1 positional argument(s) expected, but 0 found.

lib/src/field_value_web.dart:15:35

   ╷
15 │   FieldValueWeb(this.data) : super();
   │                                   ^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/field_value_web.dart

INFO: 'await' applied to 'Transaction', which is not a 'Future'.

lib/src/transaction_web.dart:24:5

   ╷
24 │     await _webTransaction
   │     ^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/transaction_web.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
cloud_firestore_platform_interface^1.0.01.1.22.2.0
firebase^7.0.07.3.27.3.2
firebase_core^0.4.3+10.4.50.5.2
http_parser^3.1.33.1.43.1.4
js^0.6.10.6.3-nullsafety.30.6.3-nullsafety.3
meta^1.1.71.3.0-nullsafety.61.3.0-nullsafety.6
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.51.1.0-nullsafety.5
charcode-1.1.31.2.0-nullsafety.3
collection-1.15.0-nullsafety.51.15.0-nullsafety.5
http-0.12.20.12.2
matcher-0.12.90.12.10-nullsafety.3
path-1.7.01.8.0-nullsafety.3
plugin_platform_interface-1.0.31.0.3
quiver-2.1.52.1.5
source_span-1.7.01.8.0-nullsafety.4
stack_trace-1.9.61.10.0-nullsafety.6
string_scanner-1.0.51.1.0-nullsafety.3
term_glyph-1.1.01.2.0-nullsafety.3
typed_data-1.3.0-nullsafety.51.3.0-nullsafety.5
vector_math-2.1.0-nullsafety.52.1.0-nullsafety.5

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.0.0` on cloud_firestore_platform_interface does not support the latest published version `2.2.0`

pubspec.yaml:22:39

   ╷
22 │   cloud_firestore_platform_interface: "^1.0.0"
   │                                       ^^^^^^^^
   ╵
The constraint `^0.4.3+1` on firebase_core does not support the latest published version `0.5.2`

pubspec.yaml:21:18

   ╷
21 │   firebase_core: ^0.4.3+1
   │                  ^^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs