cloud_firestore 0.14.3
cloud_firestore: ^0.14.3 copied to clipboard

Flutter plugin for Cloud Firestore, a cloud-hosted, noSQL database with live synchronization and offline support on Android and iOS.

1300
likes
100 / 110
pub points
99 %
popularity

We analyzed this package on Apr 8, 2021, and awarded it 100 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 100 out of 115 API elements (87.0 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Found 3 issues. Showing the first 2:

Consider supporting these prerelease platforms:

Package does not support Flutter platform Windows

Because:

  • package:cloud_firestore/cloud_firestore.dart that declares support for platforms: Android, iOS, macOS, Web
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
cloud_firestore_platform_interface^2.2.02.2.04.0.1
cloud_firestore_web^0.2.10.2.11.0.4
firebase_core^0.5.20.5.21.0.3
firebase_core_platform_interface>=2.0.0 <2.1.02.0.04.0.0
flutterflutter0.0.00.0.0
meta^1.0.51.3.01.3.0
quiver>=2.0.0 <3.0.02.1.53.0.1
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
charcode-1.2.01.2.0
collection-1.15.01.15.0
firebase_core_web-0.2.11.0.2
flutter_web_plugins-0.0.00.0.0
http_parser-3.1.44.0.0
js-0.6.30.6.3
matcher-0.12.100.12.10
path-1.8.01.8.0
plugin_platform_interface-1.0.32.0.0
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 5 issues. Showing the first 2:

The constraint `^2.2.0` on cloud_firestore_platform_interface does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions cloud_firestore_platform_interface to update the constraint.

The constraint `^0.2.1` on cloud_firestore_web does not support the stable version `0.3.0`.

Try running dart pub upgrade --major-versions cloud_firestore_web to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Flutter 2.0.4, Dart 2.12.2.

1300
likes
100
pub points
99%
popularity

Publisher

firebase.google.com

Flutter plugin for Cloud Firestore, a cloud-hosted, noSQL database with live synchronization and offline support on Android and iOS.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

cloud_firestore_platform_interface, cloud_firestore_web, firebase_core, firebase_core_platform_interface, flutter, meta, quiver

More

Packages that depend on cloud_firestore