large Flutter Favorite logosmall Flutter Favorite logo

cloud_firestore 3.5.1 icon indicating copy to clipboard operation
cloud_firestore: ^3.5.1 copied to clipboard

Flutter plugin for Cloud Firestore, a cloud-hosted, noSQL database with live synchronization and offline support on Android and iOS.

2481
likes
130/ 140
pub points
100%
popularity

We analyzed this package 3 hours ago, and awarded it 130 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

10/10 points: Package has an example

0/10 points: Failed to run dartdoc

  • Failed to resolve dependencies.
stdout: [ +112 ms] executing: uname -m
[  +64 ms] Exit code 0 from: uname -m
[        ] x86_64
[   +9 ms] executing: [/tool/stable/flutter/] git -c log.showSignature=false log[...]
[   +8 ms] Exit code 0 from: git -c log.showSignature=false log -n 1 --pretty=format:%H
[        ] 18a827f3933c19f51862dde3fa472197683249d6
[   +1 ms] executing: [/tool/stable/flutter/] git tag --points-at 18a827f3933c19[...]
[  +30 ms] Exit code 0 from: git tag --points-at 18a827f3933c19f51862dde3fa472197683249d6
[        ] 3.3.3
[ +100 ms] Unable to locate an Android SDK.
[   +4 ms] executing: [/tool/stable/flutter/] git rev-parse --abbrev-ref HEAD
[   +6 ms] Exit code 0 from: git rev-parse --abbrev-ref HEAD
[        ] HEAD
[        ] executing: [/tool/stable/flutter/] git rev-parse --abbrev-ref --symbo[...]
[   +5 ms] Exit code 128 from: git rev-parse --abbrev-ref --symbolic @{upstream}
[        ] fatal: HEAD does not point to a branch
[  +99 ms] Artifact Instance of 'AndroidGenSnapshotArtifacts' is not required, s[...]
[        ] Artifact Instance of 'AndroidInternalBuildArtifacts' is not required,[...]
[        ] Artifact Instance of 'IOSEngineArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'FlutterWebSdk' is not required, skipping update.
[...]
[        ] Artifact Instance of 'LinuxEngineArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'LinuxFuchsiaSDKArtifacts' is not required, skip[...]
[        ] Artifact Instance of 'MacOSFuchsiaSDKArtifacts' is not required, skip[...]
[        ] Artifact Instance of 'FlutterRunnerSDKArtifacts' is not required, ski[...]
[        ] Artifact Instance of 'FlutterRunnerDebugSymbols' is not required, ski[...]
[        ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'FontSubsetArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'PubDependencies' is not required, skipping update.
[  +78 ms] executing: /tool/stable/flutter/bin/cache/dart-sdk/bin/dart __depreca[...]
MSG : Resolving dependencies...
MSG : Logs written to /tmp/tool-envBNZZPG/pub-cache-dirABDEAP/log/pub_log.txt.
[+1624 ms] "flutter pub" took 1,804ms.
[   +3 ms] Running shutdown hooks
[        ] Shutdown hooks complete
[   +1 ms] exiting with code 1

stderr: FINE: Pub 2.18.2
SLVR: fact: cloud_firestore is 3.5.1
SLVR: derived: cloud_firestore
SLVR: fact: cloud_firestore depends on cloud_firestore_platform_interface ^5.7.7
SLVR: fact: cloud_firestore depends on cloud_firestore_web ^2.8.10
SLVR: fact: cloud_firestore depends on collection ^1.0.0
SLVR: fact: cloud_firestore depends on firebase_core ^1.10.2
SLVR: fact: cloud_firestore depends on firebase_core_platform_interface ^4.5.1
SLVR: fact: cloud_firestore depends on flutter from sdk
SLVR: fact: cloud_firestore depends on meta ^1.3.0
SLVR:   selecting cloud_firestore
SLVR:   derived: meta ^1.3.0
SLVR:   derived: flutter from sdk
SLVR:   derived: firebase_core_platform_interface ^4.5.1
SLVR:   derived: firebase_core ^1.10.2
SLVR:   derived: collection ^1.0.0
SLVR:   derived: cloud_firestore_web ^2.8.10
SLVR:   derived: cloud_firestore_platform_interface ^5.7.7
IO  : Get versions from https://pub.dartlang.org/api/packages/cloud_firestore_pl[...]
IO  : Get versions from https://pub.dartlang.org/api/packages/cloud_firestore_web.
[...]
           <asynchronous suspension>
           #4      AppContext.run.<anonymous closure> (package:flutter_tools/src[...]
           <asynchronous suspension>
           #5      CommandRunner.runCommand (package:args/command_runner.dart:209:13)
           <asynchronous suspension>
           #6      FlutterCommandRunner.runCommand.<anonymous closure> (package:[...]
           <asynchronous suspension>
           #7      AppContext.run.<anonymous closure> (package:flutter_tools/src[...]
           <asynchronous suspension>
           #8      FlutterCommandRunner.runCommand (package:flutter_tools/src/ru[...]
           <asynchronous suspension>
           #9      run.<anonymous closure>.<anonymous closure> (package:flutter_[...]
           <asynchronous suspension>
           #10     AppContext.run.<anonymous closure> (package:flutter_tools/src[...]
           <asynchronous suspension>
           #11     main (package:flutter_tools/executable.dart:91:3)
           <asynchronous suspension>



icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 4 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ MacOS
  • ✓ Web

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:cloud_firestore/cloud_firestore.dart that declares support for platforms: Android, iOS, macOS, Web.
Package does not support platform `Linux`.

Because:

  • package:cloud_firestore/cloud_firestore.dart that declares support for platforms: Android, iOS, macOS, Web.

These issues are present but do not affect the score, because they may not originate in your package:

Package not compatible with platform Web

Because:

  • package:cloud_firestore/cloud_firestore.dart that imports:
  • package:firebase_core_platform_interface/firebase_core_platform_interface.dart that imports:
  • package:firebase_core_platform_interface/src/pigeon/test_api.dart that imports:
  • package:flutter_test/flutter_test.dart that imports:
  • package:flutter_test/src/widget_tester.dart that imports:
  • package:flutter_test/src/test_text_input.dart that imports:
  • package:flutter_test/src/deprecated.dart that imports:
  • package:flutter_test/src/binding.dart that imports:
  • package:flutter_test/src/platform.dart that imports:
  • dart:io
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
cloud_firestore_platform_interface^5.7.75.7.75.7.7
cloud_firestore_web^2.8.102.8.102.8.10
collection^1.0.01.16.01.16.0
firebase_core^1.10.21.24.01.24.0
firebase_core_platform_interface^4.5.14.5.14.5.1
flutterflutter0.0.00.0.0
meta^1.3.01.8.01.8.0
Transitive dependencies
PackageConstraintCompatibleLatest
_flutterfire_internals-1.0.21.0.2
async-2.9.02.9.0
boolean_selector-2.1.02.1.0
characters-1.2.11.2.1
clock-1.1.11.1.1
fake_async-1.3.11.3.1
firebase_core_web-1.7.31.7.3
flutter_test-0.0.00.0.0
flutter_web_plugins-0.0.00.0.0
js-0.6.40.6.4
matcher-0.12.120.12.12
material_color_utilities-0.1.50.2.0
path-1.8.21.8.2
plugin_platform_interface-2.1.32.1.3
sky_engine-0.0.990.0.99
source_span-1.9.01.9.1
stack_trace-1.10.01.10.0
stream_channel-2.1.02.1.1
string_scanner-1.1.11.1.1
term_glyph-1.2.11.2.1
test_api-0.4.120.4.14
vector_math-2.1.22.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.18, Flutter 3.3.3, Dart 2.18.2.

2481
likes
130
pub points
100%
popularity

Publisher

verified publisher iconfirebase.google.com

Flutter plugin for Cloud Firestore, a cloud-hosted, noSQL database with live synchronization and offline support on Android and iOS.

Homepage
Repository (GitHub)
View/report issues

License

Icon for licenses.BSD-3-Clause (LICENSE)

Dependencies

cloud_firestore_platform_interface, cloud_firestore_web, collection, firebase_core, firebase_core_platform_interface, flutter, meta

More

Packages that depend on cloud_firestore