cli_dialog 0.5.0 copy "cli_dialog: ^0.5.0" to clipboard
cli_dialog: ^0.5.0 copied to clipboard

Create beautiful and powerful CLI prompts in Inquirer.js style and test them.

34
likes
130/ 140
pub points
64%
popularity

We analyzed this package 3 hours ago, and awarded it 130 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-2-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

45 out of 48 API elements (93.8 %) have documentation comments.

Some symbols that are missing documentation: cli_dialog, cli_dialog.CLI_Dialog.getCustomNavList, cli_dialog.console.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package does not support platform `Android`.

Because:

  • package:cli_dialog/cli_dialog.dart that imports:
  • package:cli_dialog/src/services.dart that imports:
  • package:cli_dialog/src/stdin_service.dart that imports:
  • package:dart_console/dart_console.dart that declares support for platforms: Windows, Linux, macOS.
Package does not support platform `iOS`.

Because:

  • package:cli_dialog/cli_dialog.dart that imports:
  • package:cli_dialog/src/services.dart that imports:
  • package:cli_dialog/src/stdin_service.dart that imports:
  • package:dart_console/dart_console.dart that declares support for platforms: Windows, Linux, macOS.
Package does not support platform `Web`.

Because:

  • package:cli_dialog/cli_dialog.dart that imports:
  • package:cli_dialog/src/services.dart that imports:
  • package:cli_dialog/src/stdin_service.dart that imports:
  • package:dart_console/dart_console.dart that declares support for platforms: Windows, Linux, macOS.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Linux`.

Because:

  • package:cli_dialog/cli_dialog.dart that imports:
  • package:cli_dialog/src/services.dart that imports:
  • package:cli_dialog/src/stdin_service.dart that imports:
  • package:dart_console/dart_console.dart that imports:
  • package:dart_console/src/console.dart that imports:
  • package:dart_console/src/ffi/win/termlib_win.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `macOS`.

Because:

  • package:cli_dialog/cli_dialog.dart that imports:
  • package:cli_dialog/src/services.dart that imports:
  • package:cli_dialog/src/stdin_service.dart that imports:
  • package:dart_console/dart_console.dart that imports:
  • package:dart_console/src/console.dart that imports:
  • package:dart_console/src/ffi/win/termlib_win.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 15 issues. Showing the first 2:

INFO: The type name '_questionType' isn't an UpperCamelCase identifier.

lib/src/dialog.dart:7:6

  ╷
7 │ enum _questionType { message, question, booleanQuestion, listQuestion }
  │      ^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/dialog.dart

INFO: The type name 'CLI_Dialog' isn't an UpperCamelCase identifier.

lib/src/dialog.dart:10:7

   ╷
10 │ class CLI_Dialog {
   │       ^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/dialog.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
dart_console ^1.0.0 1.2.0 4.0.2
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
ffi - 2.1.2 2.1.2
intl - 0.18.1 0.19.0
meta - 1.14.0 1.14.0
path - 1.9.0 1.9.0
win32 - 5.5.0 5.5.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.0.0` on dart_console does not support the stable version `4.0.0`, that was published 17 days ago.

When dart_console is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions dart_console to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.3.3.

Check the analysis log for details.

34
likes
130
pub points
64%
popularity

Publisher

verified publisherbraguinski.de

Create beautiful and powerful CLI prompts in Inquirer.js style and test them.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-2-Clause (LICENSE)

Dependencies

dart_console

More

Packages that depend on cli_dialog