cli_dialog 0.5.0
cli_dialog: ^0.5.0 copied to clipboard

Create beautiful and powerful CLI prompts in Inquirer.js style and test them.

  • 0.0.1: Initial version (experimental).
  • 0.1.0: Bump to 0.1.0 to increase score.
  • 0.1.1: Small health improvement.
  • 0.1.2: Compatible update to the addQuestion(s) methods and add documentation.
  • 0.1.3: Finish documentation for API reference.
  • 0.1.4: Add support for Windows (with caveats).
  • 0.1.5: Fix addQuestion() and create example for it. Fix tests and enable Travis CI for Windows.
  • 0.2.0: Add navigation mode and messages.
  • 0.2.1: Use 'stricter than effective' linting
  • 0.3.0: Fix issue with order and improve some comments
  • 0.3.1: Add code coverage badge, clean up repo
  • 0.3.2: Use Coveralls
  • 0.3.3: Add badge for pub version
  • 0.4.0: Introduce arrow keys for Windows. 's' and 'w' are kept on Windows for backwards-compability.
  • 0.5.0: 'dart migrate' and update README
19
likes
120
pub points
83%
popularity

Publisher

braguinski.de

Create beautiful and powerful CLI prompts in Inquirer.js style and test them.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-2-Clause (LICENSE)

Dependencies

dart_console

More

Packages that depend on cli_dialog