clean_android_design 0.0.167
clean_android_design: ^0.0.167 copied to clipboard

Provides structure and items for a clean Android-App design

0
likes
60/ 130
pub points
53%
popularity

We analyzed this package on Oct 25, 2021, and awarded it 60 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL is insecure.

Update the homepage field and use a secure (https) URL.

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 50 out of 558 API elements (9.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Found 3 issues. Showing the first 2:

Consider supporting these prerelease platforms:

Package does not support Flutter platform `Windows`.

Because:

  • package:clean_android_design/clean_android_design.dart that imports:
  • package:clean_android_design/src/structure/list/list_scaffold_widget.dart that imports:
  • package:cloud_firestore/cloud_firestore.dart that declares support for platforms: Android, iOS, macOS, Web.
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/src/dialog/datetime_picker_dialog.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
cloud_firestoreany2.5.42.5.4
flutterflutter0.0.00.0.0
intl^0.16.10.16.10.17.0
providerany6.0.16.0.1
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.2.0
cloud_firestore_platform_interface-5.4.35.4.3
cloud_firestore_web-2.4.42.4.4
collection-1.15.01.15.0
firebase_core-1.8.01.8.0
firebase_core_platform_interface-4.0.14.0.1
firebase_core_web-1.1.01.1.0
flutter_web_plugins-0.0.00.0.0
js-0.6.30.6.3
meta-1.7.01.7.0
nested-1.0.01.0.0
path-1.8.01.8.0
plugin_platform_interface-2.0.22.0.2
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.16.1` on intl does not support the stable version `0.17.0`.

Try running dart pub upgrade --major-versions intl to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.8.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.3, Flutter 2.5.2, Dart 2.14.3.

0
likes
60
pub points
53%
popularity

Provides structure and items for a clean Android-App design

Homepage (insecure)

Documentation

API reference

License

unknown (LICENSE)

Dependencies

cloud_firestore, flutter, intl, provider

More

Packages that depend on clean_android_design