check_version 0.0.7
check_version: ^0.0.7 copied to clipboard

Check Android/iOs store version and provide update alert if update is available on stores.

1
likes
90/ 130
pub points
22%
popularity

We analyzed this package on Sep 16, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 8 out of 37 API elements (21.6 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 5 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:check_version/check_version.dart that imports:
  • package:check_version/src/check_version.dart that imports:
  • package:package_info/package_info.dart that declares support for platforms: Android, iOS, macOS.
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
html^0.14.0+40.14.0+40.15.0
http^0.12.0+40.12.20.13.3
package_info^0.4.3+20.4.3+42.0.2
url_launcher^5.4.25.7.106.0.10
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.2.0
charcode-1.3.11.3.1
collection-1.15.01.15.0
csslib-0.16.20.17.0
flutter_web_plugins-0.0.00.0.0
http_parser-3.1.44.0.0
js-0.6.30.6.3
meta-1.3.01.7.0
path-1.8.01.8.0
pedantic-1.11.11.11.1
plugin_platform_interface-1.0.32.0.1
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
url_launcher_linux-0.0.1+42.0.2
url_launcher_macos-0.0.1+92.0.2
url_launcher_platform_interface-1.0.92.0.4
url_launcher_web-0.1.5+32.0.4
url_launcher_windows-0.0.1+32.0.2
vector_math-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `^0.14.0+4` on html does not support the stable version `0.15.0`.

Try running dart pub upgrade --major-versions html to update the constraint.

The constraint `^0.12.0+4` on http does not support the stable version `0.13.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.20.0, Flutter 2.2.3, Dart 2.13.4.

1
likes
90
pub points
22%
popularity

Check Android/iOs store version and provide update alert if update is available on stores.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

flutter, html, http, package_info, url_launcher

More

Packages that depend on check_version