chatscreen 0.0.1+2
chatscreen: ^0.0.1+2 copied to clipboard

An easy way to add chat to your project

6
likes
60/ 130
pub points
28%
popularity

We analyzed this package 9 hours ago, and awarded it 60 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 12 out of 241 API elements (5.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:chatscreen/chatscreen.dart that imports:
  • package:chatscreen/components/messagebubble/image_message_bubble.dart that imports:
  • package:chatscreen/components/gallery_photo_wrapper.dart that imports:
  • package:cached_network_image/cached_network_image.dart that imports:
  • package:cached_network_image/src/image_provider/cached_network_image_provider.dart that imports:
  • package:cached_network_image/src/image_provider/_image_provider_web.dart that imports:
  • package:flutter_cache_manager/flutter_cache_manager.dart that imports:
  • package:flutter_cache_manager/src/storage/cache_info_repositories/cache_info_repositories.dart that imports:
  • package:flutter_cache_manager/src/storage/cache_info_repositories/json_cache_info_repository.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS, Windows, Linux, macOS.
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
cached_network_image^2.1.0+12.5.13.2.0
cloud_firestore^0.13.50.13.73.1.4
firebase_core^0.4.4+30.4.51.10.5
firebase_database^3.1.53.1.69.0.2
firebase_storage^3.1.53.1.610.2.3
flutterflutter0.0.00.0.0
flutter_icons^1.0.0+11.1.01.1.0
image_picker^0.6.40.6.7+220.8.4+4
parse_server_sdk^1.0.261.0.283.1.0
permission_handler^5.0.0+hotfix.35.1.0+28.3.0
photo_view^0.9.10.9.20.13.0
pull_to_refresh^1.5.81.6.52.0.0
shimmer^1.1.01.1.22.0.0
uuid^2.0.42.2.23.0.5
video_player^0.10.8+10.10.12+52.2.7
video_thumbnail^0.2.00.2.5+10.4.3
Transitive dependencies
PackageConstraintCompatibleLatest
archive-2.0.133.1.6
args-1.6.02.3.0
async-2.8.22.8.2
characters-1.1.01.2.0
charcode-1.3.11.3.1
clock-1.1.01.1.0
cloud_firestore_platform_interface-1.1.25.4.9
cloud_firestore_web-0.1.1+22.6.4
collection-1.15.01.15.0
convert-2.1.13.0.1
crypto-2.1.53.0.1
dio-3.0.104.0.4
ffi-1.1.21.1.2
file-6.1.26.1.2
firebase-7.3.39.0.2
firebase_core_platform_interface-1.0.44.2.2
firebase_core_web-0.1.1+21.5.2
flutter_blurhash-0.5.00.6.0
flutter_cache_manager-2.1.23.3.0
flutter_plugin_android_lifecycle-1.0.112.0.5
flutter_web_plugins-0.0.00.0.0
http-0.12.20.13.4
http_parser-3.1.44.0.0
idb_shim-1.12.2+32.0.1
image-2.1.193.1.0
image_picker_platform_interface-1.1.62.4.1
js-0.6.30.6.3
matcher-0.12.110.12.11
meta-1.7.01.7.0
mime_type-0.3.21.0.0
octo_image-0.3.01.0.1
path-1.8.01.8.0
path_provider-2.0.72.0.7
path_provider_android-2.0.92.0.9
path_provider_ios-2.0.72.0.7
path_provider_linux-2.1.22.1.2
path_provider_macos-2.0.32.0.4
path_provider_platform_interface-2.0.02.0.1
path_provider_windows-2.0.42.0.4
pedantic-1.11.11.11.1
permission_handler_platform_interface-2.0.23.7.0
petitparser-3.1.04.4.0
platform-3.1.03.1.0
plugin_platform_interface-1.0.32.0.2
process-4.2.44.2.4
quiver-2.1.53.0.1+1
rxdart-0.25.00.27.3
sembast-2.4.10+43.1.1
sembast_web-1.2.0+12.0.1+1
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
sqflite-2.0.12.0.1
sqflite_common-2.0.1+12.0.1+1
stack_trace-1.10.01.10.0
stream_channel-2.1.02.1.0
string_scanner-1.1.01.1.0
synchronized-3.0.03.0.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1
video_player_platform_interface-2.2.04.2.0
video_player_web-0.1.4+12.0.4
web_socket_channel-1.2.02.1.0
win32-2.3.12.3.1
xdg_directories-0.2.00.2.0
xml-4.5.15.3.1
xxtea-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 14 issues. Showing the first 2:

The constraint `^2.1.0+1` on cached_network_image does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions cached_network_image to update the constraint.

The constraint `^0.13.5` on cloud_firestore does not support the stable version `0.14.0`.

Try running dart pub upgrade --major-versions cloud_firestore to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.1.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Flutter 2.5.3, Dart 2.14.4.