centrifuge 0.5.1
centrifuge: ^0.5.1 copied to clipboard

Dart client to communicate with Centrifuge and Centrifugo from Flutter and VM over dart:io WebSocket

8
likes
50 / 110
pub points
81 %
popularity

We analyzed this package on Apr 13, 2021, and awarded it 50 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL is insecure.

Update the homepage field and use a secure (https) URL.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 10 out of 95 API elements (10.5 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:centrifuge/centrifuge.dart that imports:
  • package:centrifuge/src/subscription.dart that imports:
  • package:centrifuge/src/client.dart that imports:
  • package:centrifuge/src/transport.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 213 issues. Showing the first 2:

INFO: `Future` results in `async` function bodies must be `await`ed or marked `unawaited` using `package:pedantic`.

lib/src/client.dart:205:7

    ╷
205 │       _connect();
    │       ^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/client.dart

INFO: 'copyWith' is deprecated and shouldn't be used. Using this can add significant size overhead to your binary. Use [GeneratedMessageGenericExtensions.rebuild] instead. Will be removed in next major version.

lib/src/proto/client.pb.dart:33:13

   ╷
33 │       super.copyWith((message) => updates(message as Error));
   │             ^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/proto/client.pb.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
meta^1.1.51.3.01.3.0
protobuf^1.0.11.1.32.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
fixnum-0.10.111.0.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.0.1` on protobuf does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions protobuf to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Dart 2.12.2.

8
likes
50
pub points
81%
popularity

Dart client to communicate with Centrifuge and Centrifugo from Flutter and VM over dart:io WebSocket

Repository
View/report issues

Documentation

API reference

Uploaders

saprykin.h@gmail.com
frvzmb@gmail.com

License

MIT (LICENSE)

Dependencies

meta, protobuf

More

Packages that depend on centrifuge