cdcr_connector 1.0.0+1

Flutter Android iOS

CDCR Connector Package. Requires/uses Dio package. Assumes the traversal through an F5 appliance.

0
likes
70 / 110
pub points
0 %
popularity

We analyzed this package on Sep 19, 2020, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://github.com/kabnfever/cdcr_connector.git was unreachable.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 6 out of 14 API elements (42.9 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:cdcr_connector/cdcr_connector.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS, Windows, Linux, macOS

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support Flutter platform Android

Because:

  • package:cdcr_connector/cdcr_connector.dart that imports:
  • package:path_provider/path_provider.dart that imports:
  • package:path_provider_windows/path_provider_windows.dart that declares support for platforms: Windows
Package does not support Flutter platform iOS

Because:

  • package:cdcr_connector/cdcr_connector.dart that imports:
  • package:path_provider/path_provider.dart that imports:
  • package:path_provider_windows/path_provider_windows.dart that declares support for platforms: Windows
Package does not support Flutter platform Windows

Because:

  • package:cdcr_connector/cdcr_connector.dart that imports:
  • package:path_provider/path_provider.dart that imports:
  • package:path_provider_linux/path_provider_linux.dart that declares support for platforms: Linux
Package does not support Flutter platform Linux

Because:

  • package:cdcr_connector/cdcr_connector.dart that imports:
  • package:path_provider/path_provider.dart that imports:
  • package:path_provider_windows/path_provider_windows.dart that declares support for platforms: Windows
Package does not support Flutter platform macOS

Because:

  • package:cdcr_connector/cdcr_connector.dart that imports:
  • package:path_provider/path_provider.dart that imports:
  • package:path_provider_windows/path_provider_windows.dart that declares support for platforms: Windows
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
connectivity_widget^0.1.10.1.70.1.7
cookie_jar^1.0.01.0.11.0.1
cupertino_icons^0.1.20.1.31.0.0
dio^2.1.72.2.23.0.10
flutterflutter0.0.00.0.0
http^0.12.0+20.12.20.12.2
intl^0.15.80.15.80.16.1
path_provider^1.1.01.6.161.6.16
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.0.01.0.0
charcode-1.1.31.1.3
collection-1.14.131.14.13
ffi-0.1.30.1.3
file-5.2.15.2.1
http_parser-3.1.43.1.4
meta-1.1.81.2.3
path-1.7.01.7.0
path_provider_linux-0.0.1+20.0.1+2
path_provider_macos-0.0.4+40.0.4+4
path_provider_platform_interface-1.0.31.0.3
path_provider_windows-0.0.20.0.2
pedantic-1.9.01.9.2
platform-2.2.12.2.1
plugin_platform_interface-1.0.21.0.2
process-3.0.133.0.13
rxdart-0.24.10.24.1
simple_connectivity-0.1.10.1.1
sky_engine-0.0.990.0.99
source_span-1.7.01.7.0
stream_disposable-0.1.00.1.0
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
typed_data-1.2.01.2.0
vector_math-2.0.82.0.8
win32-1.7.11.7.1
xdg_directories-0.1.00.1.2

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^0.1.2` on cupertino_icons does not support the latest published version `1.0.0`

pubspec.yaml:21:20

   ╷
21 │   cupertino_icons: ^0.1.2
   │                    ^^^^^^
   ╵
The constraint `^2.1.7` on dio does not support the latest published version `3.0.10`

pubspec.yaml:14:8

   ╷
14 │   dio: ^2.1.7 
   │        ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
70
pub points
0%
popularity

CDCR Connector Package. Requires/uses Dio package. Assumes the traversal through an F5 appliance.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

kevin.a.baroni@gmail.com

License

unknown (LICENSE)

Dependencies

connectivity_widget, cookie_jar, cupertino_icons, dio, flutter, http, intl, path_provider

More

Packages that depend on cdcr_connector