card_settings 2.0.2
card_settings: ^2.0.2 copied to clipboard

A flutter package for building card based settings forms. This includes a library of pre-built form field widgets.

126
likes
90 / 130
pub points
86 %
popularity

We analyzed this package on May 13, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/example.md

10/10 points: 20% or more of the public API has dartdoc comments

  • 331 out of 538 API elements (61.5 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package not compatible with runtime flutter-web on Web

Because:

  • package:card_settings/card_settings.dart that imports:
  • package:card_settings/widgets/numeric_fields/card_settings_slider.dart that imports:
  • package:flutter_cupertino_settings/flutter_cupertino_settings.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 15 issues. Showing the first 2:

INFO: The library 'package:flutter_cupertino_settings/flutter_cupertino_settings.dart' is legacy, and should not be imported into a null safe library.

lib/widgets/action_fields/card_settings_button.dart:8:8

  ╷
8 │ import 'package:flutter_cupertino_settings/flutter_cupertino_settings.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/widgets/action_fields/card_settings_button.dart

INFO: The library 'package:flutter_cupertino_settings/flutter_cupertino_settings.dart' is legacy, and should not be imported into a null safe library.

lib/widgets/card_settings_panel.dart:9:8

  ╷
9 │ import 'package:flutter_cupertino_settings/flutter_cupertino_settings.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/widgets/card_settings_panel.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
extended_masked_text^2.1.02.1.02.1.0
flutterflutter0.0.00.0.0
flutter_cupertino_settings^0.4.00.4.00.5.0
flutter_material_pickers^2.1.12.1.12.1.1
flutter_multi_formatter^2.0.22.0.32.0.3
flutter_web_pluginsflutter0.0.00.0.0
intl^0.17.00.17.00.17.0
meta^1.2.41.3.01.3.0
pattern_formatter^2.0.02.0.02.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
clock-1.1.01.1.0
collection-1.15.01.15.0
cupertino_icons-1.0.31.0.3
file_picker-3.0.13.0.1
flutter_colorpicker-0.4.00.4.0
flutter_plugin_android_lifecycle-2.0.12.0.1
js-0.6.30.6.3
path-1.8.01.8.0
plugin_platform_interface-2.0.02.0.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.4.0` on flutter_cupertino_settings does not support the stable version `0.5.0`, that was published 13 days ago.

When flutter_cupertino_settings is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions flutter_cupertino_settings to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Null safety support has one or more issues.

Package is not null safe

Because:

  • card_settings that depends on:
  • flutter_cupertino_settings that doesn't opt in to null safety
For more information

Try running dart pub outdated --mode=null-safety. Be sure to read the migration guide.

Analysed with Pana 0.16.0, Flutter 2.0.6, Dart 2.12.3.