carapacik_lints 1.7.0 copy "carapacik_lints: ^1.7.0" to clipboard
carapacik_lints: ^1.7.0 copied to clipboard

The most necessary lints for Flutter to encourage good coding practices

10
likes
140/ 140
pub points
58%
popularity

We analyzed this package 2 days ago, and awarded it 140 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

1 out of 1 API elements (100.0 %) have documentation comments.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

No dependencies.

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Dart 3.3.0.

Check the analysis log for details.

10
likes
140
pub points
58%
popularity

Publisher

verified publishercarapacik.dev

The most necessary lints for Flutter to encourage good coding practices

Repository (GitHub)
View/report issues

Topics

#analysis #lint #lints #linter

Documentation

API reference

License

MIT (LICENSE)

More

Packages that depend on carapacik_lints