pub version

This package contains a recommended set of lints for Flutter apps, packages, and plugins to encourage good coding practices.


Add carapacik_lints as dev dependency to your pubspec.yaml.

  carapacik_lints: ^1.8.1

Create an analysis_options.yaml file at the root of the project with the following content:

include: package:carapacik_lints/core.yaml

Package versions table

Flutter Dart Package
2.10.x 2.16.x 1.0.8
3.0.x 2.17.x 1.1.7
3.3.x 2.18.x 1.2.3
3.7.x 2.19.x 1.3.2
3.10.x 3.0.x 1.4.2
3.13.x 3.1.x 1.5.1
3.16.x 3.2.x 1.6.0
3.19.x 3.3.x 1.7.0
3.22.x 3.4.x 1.8.1


The carapacik_lints package doesn't ship any dart source code.