builderoo 1.0.8 copy "builderoo: ^1.0.8" to clipboard
builderoo: ^1.0.8 copied to clipboard

A flutter package that allows users to submit feedback from a native mobile app or web application built using Flutter. For more information please visit https://www.builderoo.io

1
likes
140/ 160
pub points
0%
popularity

We analyzed this package 47 hours ago, and awarded it 140 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

215 out of 303 API elements (71.0 %) have documentation comments.

Some symbols that are missing documentation: builderoo, builderoo.ArFeedbackLocalizations.errorDescriptionText, builderoo.Builderoo, builderoo.Builderoo.Builderoo, builderoo.Builderoo.child.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:builderoo/builderoo.dart that imports:
  • package:builderoo/src/core/main.dart that imports:
  • package:builderoo/src/core/feedback_widget.dart that imports:
  • package:builderoo/src/screens/feedback/edit_screenshot_screen.dart that imports:
  • package:image_painter/image_painter.dart that imports:
  • package:image_painter/src/_paint_over_image.dart that imports:
  • dart:io
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 8 issues. Showing the first 2:

INFO: 'window' is deprecated and shouldn't be used. Look up the current FlutterView from the context via View.of(context) or consult the PlatformDispatcher directly instead. Deprecated to prepare for the upcoming multi-window support. This feature was deprecated after v3.7.0-32.0.pre.

lib/src/l18n/localization.dart:43:47

   ╷
43 │     WidgetsFlutterBinding.ensureInitialized().window.locale;
   │                                               ^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/l18n/localization.dart

INFO: The import of 'package:flutter/src/foundation/key.dart' is unnecessary because all of the used elements are also provided by the import of 'package:flutter/material.dart'.

lib/src/screens/feedback/edit_screenshot_screen.dart:5:8

  ╷
5 │ import 'package:flutter/src/foundation/key.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/screens/feedback/edit_screenshot_screen.dart

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
environment_config ^3.1.0 3.1.0 3.1.0
flutter flutter 0.0.0 0.0.0
flutter_localizations flutter 0.0.0 0.0.0
flutter_spinkit ^5.1.0 5.2.1 5.2.1
http ^0.13.5 0.13.6 1.2.1
image_painter ^0.4.6 0.4.6 0.7.1
provider ^6.0.3 6.1.2 6.1.2
Transitive dependencies
Package Constraint Compatible Latest
_fe_analyzer_shared - 67.0.0 72.0.0
analyzer - 6.4.1 6.7.0
args - 2.5.0 2.5.0
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
built_collection - 5.1.1 5.1.1
built_value - 8.9.2 8.9.2
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
code_builder - 4.10.0 4.10.0
collection - 1.18.0 1.19.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
dart_style - 2.3.6 2.3.6
file - 7.0.0 7.0.0
fixnum - 1.1.0 1.1.0
glob - 2.1.2 2.1.2
http_parser - 4.0.2 4.1.0
intl - 0.19.0 0.19.0
matcher - 0.12.16+1 0.12.16+1
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
nested - 1.0.0 1.0.0
package_config - 2.1.0 2.1.0
path - 1.9.0 1.9.0
pub_semver - 2.1.4 2.1.4
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
test_api - 0.7.0 0.7.2
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
watcher - 1.1.0 1.1.0
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.13.5` on http does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

The constraint `^0.4.6` on image_painter does not support the stable version `0.5.0`.

Try running dart pub upgrade --major-versions image_painter to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.7, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

1
likes
140
pub points
0%
popularity

Publisher

verified publisherbuilderoo.io

A flutter package that allows users to submit feedback from a native mobile app or web application built using Flutter. For more information please visit https://www.builderoo.io

Homepage
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

environment_config, flutter, flutter_localizations, flutter_spinkit, http, image_painter, provider

More

Packages that depend on builderoo