btcpay_client 0.1.5
btcpay_client: ^0.1.5 copied to clipboard

Library to interact with a BTCPay or BitPay server. Usable in Flutter. Basic functionality is supported.

2
likes
90 / 130
pub points
12 %
popularity

We analyzed this package on May 4, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/README.md

10/10 points: 20% or more of the public API has dartdoc comments

  • 24 out of 41 API elements (58.5 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:btcpay_client/btcpay_client.dart that imports:
  • package:btcpay_client/key_utils.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
asn1lib^0.6.00.6.51.0.0
base58check^1.0.11.0.12.0.0
convert^2.1.12.1.13.0.0
hex^0.1.20.1.20.2.0
pointycastle^1.0.21.0.23.0.1
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.2.01.2.0
collection-1.15.01.15.0
crypto-2.1.53.0.1
typed_data-1.3.01.3.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 5 issues. Showing the first 2:

The constraint `^0.6.0` on asn1lib does not support the stable version `0.7.0`.

Try running dart pub upgrade --major-versions asn1lib to update the constraint.

The constraint `^1.0.1` on base58check does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions base58check to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.4.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Dart 2.12.4.

2
likes
90
pub points
12%
popularity

Library to interact with a BTCPay or BitPay server. Usable in Flutter. Basic functionality is supported.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploaders

harmaarts@gmail.com
dominikspicher@gmail.com

License

AGPL 3.0 (COPYING)

Dependencies

asn1lib, base58check, convert, hex, pointycastle

More

Packages that depend on btcpay_client