BTCPay client library for Dart #
This client takes care of communications to a BTCPay server. This is heavily dependent on PointyCastle but eschews reflection so it can be used in Flutter.
This is not a complete library. Pairing and creating invoices is supported but other endpoints are not. Note that most of the heavy lifting is done. The generation of the SIN and the signing of requests.
Add it to your
dependencies: btcpay_client: ^0.1.2
Getting Started #
Have a look in the
example directory for several examples.
Creating a client is done by passing a URL on which to reach your BTCPay server
and either a
BigInt or a
var client = Client.fromBarePrivateKey("url-to-btcpay-server", someBigInt); await client.createInvoice(10.0, "EUR");
$ pub run test
Licence overview #
All files in this repository fall under the license specified in COPYING. The project is licensed as AGPL with a lesser clause. It may be used within a proprietary project, but the core library and any changes to it must be published online. Source code for this library must always remain free for everybody to access.
- Bump pointycastle to final release
- Use BTCPay testnet instances for examples
- Update README
- Update homepage and authors
- Initial Release
This directory contains several examples.
create_invoice.dart: Create an invoice.
get_token.dart: Get a token.
pair_client_initiated.dart: Client initiated pairing.
pair_server_initiated.dart: Server initiated pairing.
Use this package as a library
1. Depend on it
Add this to your package's pubspec.yaml file:
dependencies: btcpay_client: ^0.1.3
2. Install it
You can install packages from the command line:
$ pub get
$ flutter pub get
Alternatively, your editor might support
pub get or
flutter pub get.
Check the docs for your editor to learn more.
3. Import it
Now in your Dart code, you can use:
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
We analyzed this package on Jan 16, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
- Dart: 2.7.0
- pana: 0.13.4
Maintenance issues and suggestions
Support latest dependencies. (-10 points)
The version constraint in
pubspec.yaml does not support the latest published versions for 1 dependency (
|Dart SDK||>=2.0.0 <3.0.0|