btcpay_client 0.1.3

  • Readme
  • Changelog
  • Example
  • Installing
  • 71

BTCPay client library for Dart #

pub package

This client takes care of communications to a BTCPay server. This is heavily dependent on PointyCastle but eschews reflection so it can be used in Flutter.

This is not a complete library. Pairing and creating invoices is supported but other endpoints are not. Note that most of the heavy lifting is done. The generation of the SIN and the signing of requests.

Installing #

Add it to your pubspec.yaml:

dependencies:
  btcpay_client: ^0.1.2

Getting Started #

Have a look in the example directory for several examples.

Creating a client is done by passing a URL on which to reach your BTCPay server and either a BigInt or a AsymmetricKeyPair.

var client = Client.fromBarePrivateKey("url-to-btcpay-server", someBigInt);
await client.createInvoice(10.0, "EUR");

Tests #

$ pub run test

Licence overview #

All files in this repository fall under the license specified in COPYING. The project is licensed as AGPL with a lesser clause. It may be used within a proprietary project, but the core library and any changes to it must be published online. Source code for this library must always remain free for everybody to access.

0.1.3 #

  • Bump pointycastle to final release
  • Fix getToken()
  • Use BTCPay testnet instances for examples

0.1.2 #

  • Update README

0.1.1 #

  • Update homepage and authors

0.1.0 #

  • Initial Release

example/README.md

This directory contains several examples.

  • create_invoice.dart: Create an invoice.
  • get_token.dart: Get a token.
  • pair_client_initiated.dart: Client initiated pairing.
  • pair_server_initiated.dart: Server initiated pairing.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  btcpay_client: ^0.1.3

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:btcpay_client/btcpay_client.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
42
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
71
Learn more about scoring.

We analyzed this package on Oct 16, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21

Platforms

Detected platforms: Flutter, other

Primary library: package:btcpay_client/btcpay_client.dart with components: io.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
asn1lib ^0.5.1 0.5.8
base58check ^1.0.1 1.0.1
convert ^2.0.2 2.1.1
hex ^0.1.2 0.1.2
pointycastle ^1.0.1 1.0.1
Transitive dependencies
charcode 1.1.2
collection 1.14.12
crypto 2.1.3
typed_data 1.1.6
Dev dependencies
args ^1.5.0
mock_web_server
pedantic ^1.8.0
test ^1.3.4