brick_rest_generators 3.0.1 copy "brick_rest_generators: ^3.0.1" to clipboard
brick_rest_generators: ^3.0.1 copied to clipboard

Code generation library for the REST providers, models, and adapters in Brick

0
likes
110/ 140
pub points
23%
popularity

We analyzed this package 4 days ago, and awarded it 110 pub points (of a possible 140):

partial
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/GetDutchie/brick/issues was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

85 out of 93 API elements (91.4 %) have documentation comments.

Some symbols that are missing documentation: generators, generators.RestAnnotationFinder.config, generators.RestDeserialize.className, generators.RestDeserialize.getAssociationMethod, generators.RestFields.config.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Android

Because:

  • package:brick_rest_generators/generators.dart that imports:
  • package:brick_rest_generators/src/rest_fields.dart that imports:
  • package:brick_build/generators.dart that imports:
  • package:brick_build/src/utils/shared_checker.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/type_checker.dart that imports:
  • dart:mirrors
Package not compatible with platform iOS

Because:

  • package:brick_rest_generators/generators.dart that imports:
  • package:brick_rest_generators/src/rest_fields.dart that imports:
  • package:brick_build/generators.dart that imports:
  • package:brick_build/src/utils/shared_checker.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/type_checker.dart that imports:
  • dart:mirrors
Package not compatible with platform Web

Because:

  • package:brick_rest_generators/generators.dart that imports:
  • package:brick_rest_generators/src/rest_fields.dart that imports:
  • package:brick_build/generators.dart that imports:
  • package:brick_build/src/utils/shared_checker.dart that imports:
  • package:analyzer/dart/element/element.dart that imports:
  • package:analyzer/src/task/api/model.dart that imports:
  • package:analyzer/src/generated/source.dart that imports:
  • package:analyzer/src/generated/sdk.dart that imports:
  • package:analyzer/dart/ast/visitor.dart that imports:
  • package:analyzer/dart/ast/ast.dart that imports:
  • package:analyzer/dart/element/type.dart that imports:
  • package:analyzer/src/dart/element/type.dart that imports:
  • package:analyzer/src/generated/utilities_dart.dart that imports:
  • package:analyzer/src/dart/element/element.dart that imports:
  • package:analyzer/src/summary2/macro.dart that imports:
  • package:analyzer/src/summary2/kernel_compilation_service.dart that imports:
  • package:_fe_analyzer_shared/src/macros/compiler/request_channel.dart that imports:
  • dart:io
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 5 issues. Showing the first 2:

lib/rest_model_serdes_generator.dart doesn't match the Dart formatter.

To format your files run: dart format .

lib/src/rest_deserialize.dart doesn't match the Dart formatter.

To format your files run: dart format .

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
analyzer >=5.0.0 <6.0.0 5.13.0 6.4.1
brick_build >=3.0.0 <4.0.0 3.0.1 3.0.1
brick_core ^1.1.1 1.1.2 1.1.2
brick_json_generators >=3.0.0 <4.0.0 3.0.2 3.0.2
brick_rest >=3.0.0 <4.0.0 3.0.2 3.0.2
build >=2.0.0 <3.0.0 2.4.1 2.4.1
dart_style >=2.0.0 <3.0.0 2.3.2 2.3.6
source_gen >=1.2.2 <2.0.0 1.5.0 1.5.0
Transitive dependencies
Package Constraint Compatible Latest
_fe_analyzer_shared - 61.0.0 67.0.0
args - 2.4.2 2.4.2
async - 2.11.0 2.11.0
collection - 1.18.0 1.18.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
file - 7.0.0 7.0.0
glob - 2.1.2 2.1.2
http - 0.13.6 1.2.1
http_parser - 4.0.2 4.0.2
logging - 1.2.0 1.2.0
meta - 1.12.0 1.12.0
package_config - 2.1.0 2.1.0
path - 1.9.0 1.9.0
pub_semver - 2.1.4 2.1.4
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
watcher - 1.1.0 1.1.0
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `>=5.0.0 <6.0.0` on analyzer does not support the stable version `6.0.0`.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Dart 3.3.0.

Check the analysis log for details.

0
likes
110
pub points
23%
popularity

Publisher

unverified uploader

Code generation library for the REST providers, models, and adapters in Brick

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

analyzer, brick_build, brick_core, brick_json_generators, brick_rest, build, dart_style, source_gen

More

Packages that depend on brick_rest_generators