brick_offline_first_with_graphql 3.0.1 copy "brick_offline_first_with_graphql: ^3.0.1" to clipboard
brick_offline_first_with_graphql: ^3.0.1 copied to clipboard

A Brick domain that routes data fetching through local providers before a GraphQL provider.

1
likes
110/ 140
pub points
8%
popularity

We analyzed this package 4 days ago, and awarded it 110 pub points (of a possible 140):

partial
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/GetDutchie/brick/issues was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

66 out of 90 API elements (73.3 %) have documentation comments.

Some symbols that are missing documentation: brick_offline_first_with_graphql, brick_offline_first_with_graphql.GRAPHQL_JOBS_TABLE_NAME, brick_offline_first_with_graphql.GraphqlOfflineQueueLink.requestManager, brick_offline_first_with_graphql.GraphqlRequestSqliteCacheManager, brick_offline_first_with_graphql.GraphqlRequestSqliteCacheManager.GraphqlRequestSqliteCacheManager.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:brick_offline_first_with_graphql/brick_offline_first_with_graphql.dart that imports:
  • package:brick_offline_first_with_graphql/src/annotations/connect_offline_first_with_graphql_annotation.dart that imports:
  • package:brick_sqlite/brick_sqlite.dart that imports:
  • package:brick_sqlite/src/sqlite_provider.dart that imports:
  • dart:io
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 7 issues. Showing the first 2:

lib/src/annotations/connect_offline_first_with_graphql_annotation.dart doesn't match the Dart formatter.

To format your files run: dart format .

lib/src/graphql_offline_queue_link.dart doesn't match the Dart formatter.

To format your files run: dart format .

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
brick_core ^1.1.1 1.1.2 1.1.2
brick_graphql >=3.0.0 <4.0.0 3.0.1 3.0.1
brick_offline_first >=3.0.0 <4.0.0 3.1.0 3.1.0
brick_sqlite >=3.0.0 <4.0.0 3.0.1 3.0.1
gql >=0.13.0 <1.0.0 0.14.0 1.0.0+1
gql_exec >=0.3.0 <1.0.0 0.4.3 1.0.0+1
gql_link >=0.4.0 <1.0.0 0.5.1 1.0.0+1
logging >=1.0.0 <2.0.0 1.2.0 1.2.0
meta >=1.3.0 <2.0.0 1.14.0 1.14.0
sqflite_common >=2.0.0 <3.0.0 2.5.4 2.5.4
Transitive dependencies
Package Constraint Compatible Latest
_fe_analyzer_shared - 67.0.0 67.0.0
analyzer - 6.4.1 6.4.1
args - 2.5.0 2.5.0
async - 2.11.0 2.11.0
collection - 1.18.0 1.18.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
dart_style - 2.3.6 2.3.6
file - 7.0.0 7.0.0
glob - 2.1.2 2.1.2
http - 1.2.1 1.2.1
http_parser - 4.0.2 4.0.2
package_config - 2.1.0 2.1.0
path - 1.9.0 1.9.0
pub_semver - 2.1.4 2.1.4
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
synchronized - 3.1.0+1 3.1.0+1
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
watcher - 1.1.0 1.1.0
web - 0.5.1 0.5.1
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `>=0.13.0 <1.0.0` on gql does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions gql to update the constraint.

The constraint `>=0.3.0 <1.0.0` on gql_exec does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions gql_exec to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Dart 3.3.3.

Check the analysis log for details.

1
likes
110
pub points
8%
popularity

Publisher

unverified uploader

A Brick domain that routes data fetching through local providers before a GraphQL provider.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

brick_core, brick_graphql, brick_offline_first, brick_sqlite, gql, gql_exec, gql_link, logging, meta, sqflite_common

More

Packages that depend on brick_offline_first_with_graphql