borg 1.4.5+1
borg: ^1.4.5+1 copied to clipboard

Dart borg is a command-line tool to support development teams working on large scale Dart and Flutter mono repositories.

7
likes
100 / 110
pub points
0 %
popularity

We analyzed this package on Apr 23, 2021, and awarded it 100 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 10 out of 11 API elements (90.9 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
args^1.5.01.6.02.1.0
collection^1.14.01.15.01.15.0
functional_data^0.3.00.3.01.0.0
glob^1.2.01.2.02.0.1
json2yaml^1.0.01.0.1+11.0.1+1
meta^1.1.01.3.01.3.0
path^1.6.01.8.01.8.0
plain_optional^0.1.00.1.30.1.3
pubspec_lock^2.0.02.0.1+12.0.1+1
pubspec_yaml^2.0.02.0.1+12.0.1+1
yaml^2.2.02.2.13.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.5.02.5.0
charcode-1.2.01.2.0
clock-1.1.01.1.0
file-5.2.16.1.0
intl-0.17.00.17.0
js-0.6.30.6.3
node_interop-1.2.12.0.1
node_io-1.2.01.2.0
pedantic-1.11.01.11.0
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
sum_types-0.2.1+20.2.1+2
term_glyph-1.2.01.2.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `^1.5.0` on args does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions args to update the constraint.

The constraint `^0.3.0` on functional_data does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions functional_data to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Dart 2.12.2.

7
likes
100
pub points
0%
popularity

Dart borg is a command-line tool to support development teams working on large scale Dart and Flutter mono repositories.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

alexei.sintotski@gmail.com

License

MIT (LICENSE)

Dependencies

args, collection, functional_data, glob, json2yaml, meta, path, plain_optional, pubspec_lock, pubspec_yaml, yaml

More

Packages that depend on borg