bonfire 2.6.3 icon indicating copy to clipboard operation
bonfire: ^2.6.3 copied to clipboard

(RPG maker) Create RPG-style or similar games more simply with Flame.

221
likes
130/ 130
pub points
84%
popularity

We analyzed this package 12 hours ago, and awarded it 130 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
20 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 424 out of 1870 API elements (22.7 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
a_star_algorithm^0.3.00.3.00.3.0
flame^1.2.01.2.01.2.0
flutterflutter0.0.00.0.0
http^0.13.40.13.40.13.4
tiledjsonreader^1.1.01.1.01.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.9.02.9.0
characters-1.2.01.2.1
collection-1.16.01.16.0
http_parser-4.0.14.0.1
material_color_utilities-0.1.40.1.5
meta-1.7.01.8.0
ordered_set-5.0.05.0.0
path-1.8.21.8.2
sky_engine-0.0.990.0.99
source_span-1.9.01.9.0
string_scanner-1.1.11.1.1
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
vector_math-2.1.22.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.13, Flutter 3.0.3, Dart 2.17.5.

221
likes
130
pub points
84%
popularity

Publisher

unverified uploader

(RPG maker) Create RPG-style or similar games more simply with Flame.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

a_star_algorithm, flame, flutter, http, tiledjsonreader

More

Packages that depend on bonfire