bluesky_cli 0.4.5 copy "bluesky_cli: ^0.4.5" to clipboard
bluesky_cli: ^0.4.5 copied to clipboard

A powerful CLI tool that allows Bluesky Social's APIs to be executed from the command line powered by Dart language.

4
likes
130/ 160
pub points
0%
popularity

We analyzed this package 36 hours ago, and awarded it 130 pub points (of a possible 160):

partial
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/myConsciousness/atproto.dart/issues was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

15 out of 17 API elements (88.2 %) have documentation comments.

Some symbols that are missing documentation: bluesky_cli, bluesky_cli.entryPoint.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:bluesky_cli/bluesky_cli.dart that imports:
  • package:bluesky_cli/src/command_runner.dart that imports:
  • package:bluesky_cli/src/logger.dart that imports:
  • package:cli_util/cli_logging.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
10 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
ansi_styles ^0.3.1 0.3.2+1 0.3.2+1
args ^2.0.0 2.5.0 2.5.0
at_uri ^0.3.2 0.3.2 0.3.2
bluesky_text ^0.6.9 0.6.9 0.6.9
cli_launcher ^0.3.0 0.3.1 0.3.1
cli_util ^0.3.0 0.3.5 0.4.1
xrpc ^0.5.2 0.5.2 0.5.2
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
at_identifier - 0.2.2 0.2.2
characters - 1.3.0 1.3.0
collection - 1.19.0 1.19.0
crypto - 3.0.3 3.0.3
freezed_annotation - 2.4.1 2.4.1
http - 1.2.1 1.2.1
http_parser - 4.1.0 4.1.0
json_annotation - 4.9.0 4.9.0
meta - 1.15.0 1.15.0
mime - 1.0.5 1.0.5
nsid - 0.4.1 0.4.1
path - 1.9.0 1.9.0
source_span - 1.10.0 1.10.0
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
web - 0.5.1 0.5.1
web_socket_channel - 2.4.5 3.0.0
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.3.0` on cli_util does not support the stable version `0.4.0`.

Try running dart pub upgrade --major-versions cli_util to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

0/20 points: Compatible with dependency constraint lower bounds

downgrade analysis failed failed with 1 error:

  • UNDEFINED_NAMED_PARAMETER - lib/src/command/feed/posts.dart:19:7 - The named parameter 'mandatory' isn't defined.

Run dart pub downgrade and then dart analyze to reproduce the above problem.

You may run dart pub upgrade --tighten to update your dependency constraints, see dart.dev/go/downgrade-testing for details.

Analyzed with Pana 0.22.6, Dart 3.4.3.

Check the analysis log for details.

4
likes
130
pub points
0%
popularity

Publisher

verified publisheratprotodart.com

A powerful CLI tool that allows Bluesky Social's APIs to be executed from the command line powered by Dart language.

Homepage
Repository (GitHub)
View/report issues
Contributing

Topics

#atproto #bluesky #api #cli

Documentation

API reference

Funding

Consider supporting this project:

github.com

License

BSD-3-Clause (LICENSE)

Dependencies

ansi_styles, args, at_uri, bluesky_text, cli_launcher, cli_util, xrpc

More

Packages that depend on bluesky_cli