blox 0.0.7+9
blox: ^0.0.7+9 copied to clipboard

Content management stystem plugin (Flutter document editor/viewr)

4
likes
90/ 130
pub points
0%
popularity

We analyzed this package on Oct 22, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 56 out of 278 API elements (20.1 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Found 4 issues. Showing the first 2:

Consider supporting these prerelease platforms:

Package does not support Flutter platform `Windows`.

Because:

  • package:blox/blox.dart that declares support for platforms: Android, iOS, Web.
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/blox.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
animate_do^1.7.21.7.52.0.0
apex_flutter_sdk^1.0.61.1.1+31.1.1+3
auto_direction^0.0.4+10.0.4+10.0.5
file_picker^1.12.01.13.34.1.6
flare_flutter^2.0.52.0.63.0.2
flutterflutter0.0.00.0.0
google_fonts^1.1.01.1.22.1.0
intl^0.16.10.16.10.17.0
json_annotation^3.0.13.1.14.3.0
mbi^0.0.90.0.90.0.9
pedantic^1.9.01.11.11.11.1
stacked^1.7.41.9.82.2.7
universal_html^1.2.31.2.42.0.8
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.8.22.8.2
characters-1.1.01.2.0
charcode-1.3.11.3.1
collection-1.15.01.15.0
crypto-3.0.13.0.1
csslib-0.16.20.17.1
ffi-1.1.21.1.2
file-6.1.26.1.2
file_picker_platform_interface-1.3.12.0.0
flare_dart-2.3.42.3.4
flutter_plugin_android_lifecycle-1.0.112.0.4
get_it-6.1.17.2.0
html-0.14.0+40.15.0
http-0.12.20.13.4
http_parser-3.1.44.0.0
meta-1.7.01.7.0
nested-1.0.01.0.0
observable_ish-2.1.53.0.0
path-1.8.01.8.0
path_provider-2.0.52.0.5
path_provider_linux-2.1.02.1.0
path_provider_macos-2.0.22.0.2
path_provider_platform_interface-2.0.02.0.1
path_provider_windows-2.0.32.0.3
platform-3.0.23.0.2
plugin_platform_interface-1.0.32.0.2
process-4.2.44.2.4
provider-5.0.06.0.1
shamsi_date-0.15.00.16.0
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
universal_io-2.0.42.0.4
vector_math-2.1.02.1.1
win32-2.2.102.2.10
xdg_directories-0.2.00.2.0
zone_local-0.1.20.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 8 issues. Showing the first 2:

The constraint `^1.7.2` on animate_do does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions animate_do to update the constraint.

The constraint `^1.12.0` on file_picker does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions file_picker to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.3, Flutter 2.5.2, Dart 2.14.3.