bloom_share_kit 1.0.0
bloom_share_kit: ^1.0.0 copied to clipboard

Easily allow your users to share their verified personal information directly with your application.

0
likes
70 / 110
pub points
0 %
popularity

We analyzed this package on Apr 17, 2021, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 3 out of 72 API elements (4.2 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package not compatible with runtime flutter-web on Web

Because:

  • package:bloom_share_kit/bloom_share_kit.dart that imports:
  • package:bloom_share_kit/src/elements/elements.dart that imports:
  • package:bloom_share_kit/src/elements/request_qr_code.dart that imports:
  • package:flutter_svg/flutter_svg.dart that imports:
  • package:flutter_svg/svg.dart that imports:
  • package:flutter_svg/src/vector_drawable.dart that imports:
  • package:flutter_svg/src/svg/parsers.dart that imports:
  • package:flutter_svg/src/utilities/http.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 24 issues. Showing the first 2:

INFO: Name non-constant identifiers using lowerCamelCase.

lib/src/attestations_lib/attestation_types.dart:57:47

   ╷
57 │ final Map<AttestationTypeID, AttestationType> AttestationTypes =
   │                                               ^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/attestations_lib/attestation_types.dart

INFO: 'List' is deprecated and shouldn't be used. Use a list literal, [], or the List.filled constructor instead.

lib/src/attestations_lib/hashing_logic.dart:198:13

    ╷
198 │   var ret = List<String>(paddingCount);
    │             ^^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/attestations_lib/hashing_logic.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

  • Could not run pub outdated: pub get failed:
The current Dart SDK version is 2.12.2.

    Because test >=1.16.0-nullsafety.18 <1.16.0-nullsafety.19 depends on test_core 0.3.12-nullsafety.16 and test >=1.16.0-nullsafety.19 <1.16.0 depends on test_core 0.3.12-nullsafety.17, test >=1.16.0-nullsafety.18 <1.16.0 requires test_core 0.3.12-nullsafety.16 or 0.3.12-nullsafety.17.
    And because test >=1.12.0 <1.13.0 depends on test_api 0.2.14 and test >=1.13.0 <1.14.5 depends on test_api 0.2.15, test >=1.12.0 <1.14.5-∞ or >=1.16.0-nullsafety.18 <1.16.0 requires test_core 0.3.12-nullsafety.16 or 0.3.12-nullsafety.17 or test_api 0.2.14 or 0.2.15.
    And because test >=1.14.5 <1.15.0 depends on test_api 0.2.16 and test >=1.16.0 <1.16.2 depends on test_core 0.3.12, test >=1.12.0 <1.15.0-∞ or >=1.16.0-nullsafety.18 <1.16.2-∞ requires test_api 0.2.14 or 0.2.15 or 0.2.16 or test_core 0.3.12-nullsafety.16 or 0.3.12-nullsafety.17 or 0.3.12.
    And because test_core >=0.3.12-nullsafety.10 <0.3.13 depends on analyzer >=0.39.5 <0.42.0 and test >=1.15.5 <1.16.0-nullsafety depends on test_api 0.2.18+1, test >=1.12.0 <1.15.0-∞ or >=1.15.5 <1.16.0-nullsafety or >=1.16.0-nullsafety.18 <1.16.2-∞ requires test_api 0.2.14 or 0.2.15 or 0.2.16 or 0.2.18+1 or analyzer >=0.39.5 <0.42.0.
    And because test >=1.15.3 <1.15.5 depends on test_api 0.2.18 and test >=1.15.0 <1.15.3 depends on test_api 0.2.17, test >=1.12.0 <1.16.0-nullsafety or >=1.16.0-nullsafety.18 <1.16.2-∞ requires test_api 0.2.14 or 0.2.15 or 0.2.16 or 0.2.17 or 0.2.18 or 0.2.18+1 or analyzer >=0.39.5 <0.42.0.
    And because test >=1.3.0 <1.12.0 depends on boolean_selector ^1.0.0 and test >=1.16.0-nullsafety.8 <1.16.0-nullsafety.18 depends on typed_data >=1.3.0-nullsafety <1.3.0, test >=1.3.0 <1.16.0-nullsafety or >=1.16.0-nullsafety.8 <1.16.2-∞ requires test_api 0.2.14 or 0.2.15 or 0.2.16 or 0.2.17 or 0.2.18 or 0.2.18+1 or analyzer >=0.39.5 <0.42.0 or boolean_selector ^1.0.0 or typed_data >=1.3.0-nullsafety <1.3.0.
    And because test >=1.16.0-nullsafety <1.16.0-nullsafety.8 requires SDK version >=2.10.0-0 <2.12.0 and test >=1.16.6 depends on analyzer ^1.0.0, test >=1.3.0 <1.16.2-∞ or >=1.16.6 requires test_api 0.2.14 or 0.2.15 or 0.2.16 or 0.2.17 or 0.2.18 or 0.2.18+1 or analyzer >=0.39.5 <0.42.0 or ^1.0.0 or boolean_selector ^1.0.0 or typed_data >=1.3.0-nullsafety <1.3.0.
    And because test >=1.16.1 <1.16.6 depends on analyzer >=0.39.5 <2.0.0 and every version of flutter_test from sdk depends on boolean_selector 2.1.0, if test >=1.3.0 and flutter_test any from sdk then test_api 0.2.14 or 0.2.15 or 0.2.16 or 0.2.17 or 0.2.18 or 0.2.18+1 or analyzer >=0.39.5 <2.0.0 or typed_data >=1.3.0-nullsafety <1.3.0.
(1) So, because every version of flutter_test from sdk depends on both test_api 0.2.19 and typed_data 1.3.0, if flutter_test any from sdk and test >=1.3.0 then analyzer >=0.39.5 <2.0.0.

    Because json_serializable >=2.0.1 <2.0.2 depends on analyzer >=0.32.2 <0.35.0 and json_serializable >=1.5.1 <2.0.1 depends on analyzer >=0.32.2 <0.34.0, json_serializable >=1.5.1 <2.0.2 requires analyzer >=0.32.2 <0.35.0.
    And because json_serializable >=2.0.2 <2.1.1 depends on analyzer >=0.33.3 <0.36.0 and json_serializable >=2.1.1 <3.1.0 depends on analyzer >=0.33.3 <0.37.0, json_serializable >=1.5.1 <3.1.0 requires analyzer >=0.32.2 <0.37.0.
    And because if flutter_test any from sdk and test >=1.3.0 then analyzer >=0.39.5 <2.0.0 (1), one of flutter_test any from sdk or test >=1.3.0 or json_serializable >=1.5.1 <3.1.0 must be false.
    And because bloom_share_kit depends on json_serializable ^2.0.0, flutter_test from sdk is incompatible with test >=1.3.0.
    So, because bloom_share_kit depends on both flutter_test any from sdk and test ^1.5.0, version solving failed.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Flutter 2.0.4, Dart 2.12.2.

0
likes
70
pub points
0%
popularity

Easily allow your users to share their verified personal information directly with your application.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploaders

jace@bloom.co
dustin@bloom.co
eddie@bloom.co

License

Apache 2.0 (LICENSE)

Dependencies

buffer, collection, convert, ethereum_util, flutter, flutter_svg, json_annotation, json_serializable, merkletree, meta, qr, sortedmap, url_launcher

More

Packages that depend on bloom_share_kit