ethereum_util 1.3.0

ethereum_util #

This project is a work in progress.

Porting Ethereum utilities from Javascript to Dart:

Check test folder for usage.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  ethereum_util: ^1.3.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:ethereum_util/ethereum_util.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
58
Health:
Code health derived from static analysis. [more]
81
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
46
Overall:
Weighted score of the above. [more]
62
Learn more about scoring.

We analyzed this package on Nov 21, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.1
  • pana: 0.12.21

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:ethereum_util/ethereum_util.dart.

Health suggestions

Fix lib/src/abi.dart. (-5.84 points)

Analysis of lib/src/abi.dart reported 12 hints, including:

line 61 col 13: The value of the local variable 'i' isn't used.

line 81 col 13: Unnecessary new keyword.

line 85 col 13: Unnecessary new keyword.

line 116 col 13: Unnecessary new keyword.

line 123 col 13: Unnecessary new keyword.

Fix lib/src/typed_data.dart. (-4.41 points)

Analysis of lib/src/typed_data.dart reported 9 hints, including:

line 6 col 48: Use lowercase_with_underscores when specifying a library prefix.

line 94 col 24: Method doesn't override an inherited method.

line 108 col 24: Method doesn't override an inherited method.

line 139 col 24: Method doesn't override an inherited method.

line 194 col 17: Unnecessary new keyword.

Fix lib/src/hash.dart. (-2.96 points)

Analysis of lib/src/hash.dart reported 6 hints, including:

line 4 col 48: Use lowercase_with_underscores when specifying a library prefix.

line 10 col 38: Use = to separate a named parameter from its default value.

line 12 col 17: Unnecessary new keyword.

line 28 col 19: Unnecessary new keyword.

line 35 col 44: Use = to separate a named parameter from its default value.

Fix additional 4 files with analysis or formatting issues. (-7.45 points)

Additional issues in the following files:

  • lib/src/rlp.dart (5 hints)
  • lib/src/signature.dart (5 hints)
  • lib/src/bigint.dart (3 hints)
  • lib/src/utils.dart (2 hints)

Maintenance issues and suggestions

Provide a file named CHANGELOG.md. (-20 points)

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (equatable).

The package description is too short. (-14 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and ethereum_util.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
buffer ^1.0.6 1.0.6
collection ^1.14.11 1.14.12
convert ^2.1.1 2.1.1
equatable ^0.2.3 0.2.6 1.0.0
json_annotation ^3.0.0 3.0.0
json_schema ^2.2.0 2.2.1
meta ^1.1.6 1.1.8
pointycastle ^1.0.1 1.0.2
quiver >=2.0.0 <3.0.0 2.1.2+1
Transitive dependencies
args 1.5.2
async 2.4.0
charcode 1.1.2
cli_repl 0.2.0+1
colorize 2.0.0
dart2_constant 1.0.2+dart2
fluri 1.2.8
glob 1.2.0
http 0.12.0+2
http_parser 3.1.3
intl 0.15.8 0.16.0
js 0.6.1+1
logging 0.11.3+2
matcher 0.12.6
mime 0.9.6+3
node_interop 1.0.3
node_io 1.0.1+2
package_config 1.1.0
package_resolver 1.0.10
pedantic 1.8.0+1
sass 1.23.7
sockjs_client 0.3.5
sockjs_client_wrapper 1.0.14
source_maps 0.10.8
source_span 1.5.5
stack_trace 1.9.3
stream_transform 0.0.20 1.0.0
string_scanner 1.0.5
term_glyph 1.1.0
tuple 1.0.3
typed_data 1.1.6
uri 0.11.3+1
utf 0.9.0+5
w_common 1.20.1
w_transport 3.2.8
watcher 0.9.7+13
Dev dependencies
build_runner ^1.3.0
json_serializable ^3.0.0
path ^1.6.2 1.6.4
test ^1.6.2