blake 0.6.2 copy "blake: ^0.6.2" to clipboard
blake: ^0.6.2 copied to clipboard

Experimental static site generator for Dart with Markdown support, Jinja templates and live-reload.

8
likes
110/ 140
pub points
0%
popularity

We analyzed this package 6 days ago, and awarded it 110 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

49 out of 170 API elements (28.8 %) have documentation comments.

Some symbols that are missing documentation: blake, blake.Blake.call, blake.Blake.runner, blake.BlakeError, blake.BlakeError.BlakeError.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:blake/blake.dart that imports:
  • package:blake/src/taxonomy.dart that imports:
  • package:blake/src/content/page.dart that imports:
  • package:blake/src/git_util.dart that imports:
  • package:process_run/shell.dart that imports:
  • package:process_run/utils/process_result_extension.dart that imports:
  • package:process_run/src/lines_utils.dart that imports:
  • package:process_run/src/lines_utils_common.dart that imports:
  • package:process_run/src/common/import.dart that imports:
  • package:process_run/src/common/dartbin.dart that imports:
  • package:process_run/src/dartbin_impl.dart that imports:
  • package:process_run/src/user_config.dart that imports:
  • package:process_run/src/shell_utils.dart that imports:
  • package:process_run/src/shell_utils_common.dart that imports:
  • package:process_run/src/platform/platform.dart that imports:
  • package:process_run/src/platform/platform_stub.dart that imports:
  • package:process_run/src/shell_context_common.dart that imports:
  • package:process_run/src/shell_common.dart that imports:
  • package:process_run/src/io/io_import.dart that imports:
  • dart:io
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

WARNING: Duplicate export.

lib/blake.dart:15:8

   ╷
15 │ export 'src/content/content.dart';
   │        ^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/blake.dart

WARNING: Unused import: 'dart:io'.

lib/src/build/content_parser.dart:1:8

  ╷
1 │ import 'dart:io';
  │        ^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/build/content_parser.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
ansicolor ^2.0.1 2.0.2 2.0.2
args ^2.0.0 2.4.2 2.4.2
file ^6.1.0 6.1.4 7.0.0
glob ^2.0.1 2.1.2 2.1.2
html ^0.15.0 0.15.4 0.15.4
jinja ^0.3.1 0.3.4 0.5.0
markdown ^4.0.0 4.0.1 7.2.1
meta ^1.3.0 1.12.0 1.12.0
mime ^1.0.0 1.0.5 1.0.5
path ^1.8.0 1.9.0 1.9.0
petitparser ^4.1.0 4.4.0 6.0.2
process_run ^0.12.1 0.12.5+3 0.14.2
watcher ^1.0.0 1.1.0 1.1.0
xml ^5.1.0 5.3.1 6.5.0
yaml ^3.1.0 3.1.2 3.1.2
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
charcode - 1.3.1 1.3.1
collection - 1.18.0 1.18.0
csslib - 1.0.0 1.0.0
pub_semver - 2.1.4 2.1.4
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
synchronized - 3.1.0+1 3.1.0+1
term_glyph - 1.2.1 1.2.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 6 issues. Showing the first 2:

The constraint `^6.1.0` on file does not support the stable version `7.0.0`.

Try running dart pub upgrade --major-versions file to update the constraint.

The constraint `^0.3.1` on jinja does not support the stable version `0.4.0`.

Try running dart pub upgrade --major-versions jinja to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Dart 3.3.0.

Check the analysis log for details.

8
likes
110
pub points
0%
popularity

Publisher

verified publishervojtech.net

Experimental static site generator for Dart with Markdown support, Jinja templates and live-reload.

Homepage
Repository (GitHub)
View/report issues

Documentation

Documentation
API reference

License

MIT (LICENSE)

Dependencies

ansicolor, args, file, glob, html, jinja, markdown, meta, mime, path, petitparser, process_run, watcher, xml, yaml

More

Packages that depend on blake