blake 0.6.2
blake: ^0.6.2 copied to clipboard

Experimental static site generator for Dart with Markdown support, Jinja templates and live-reload.

Use this package as an executable

1. Install it

You can install the package from the command line:

$ dart pub global activate blake

Use it

The package has the following executables:

$ blake

Use this package as a library

Depend on it

Run this command:

With Dart:

 $ dart pub add blake

With Flutter:

 $ flutter pub add blake

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):


dependencies:
  blake: ^0.6.2

Alternatively, your editor might support dart pub get or flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:blake/blake.dart';
5
likes
120
pub points
0%
popularity

Publisher

vojtech.net

Experimental static site generator for Dart with Markdown support, Jinja templates and live-reload.

Homepage
Repository (GitHub)
View/report issues

Documentation

Documentation
API reference

License

MIT (LICENSE)

Dependencies

ansicolor, args, file, glob, html, jinja, markdown, meta, mime, path, petitparser, process_run, watcher, xml, yaml

More

Packages that depend on blake