bitcoin_flutter 2.0.2
bitcoin_flutter: ^2.0.2 copied to clipboard

A dart Bitcoin library for Flutter. BIP32, BIP39, P2PKH integration.

28
likes
80/ 130
pub points
83%
popularity

We analyzed this package 20 hours ago, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/bitcoin_flutter_example.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 2 out of 209 API elements (1.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/src/utils/push_data.dart doesn't match the Dart formatter.

To format your files run: dart format .

lib/src/utils/varuint.dart doesn't match the Dart formatter.

To format your files run: dart format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
bech320.1.20.1.20.2.1
bip32^1.0.51.0.72.0.0
bip39^1.0.31.0.31.0.6
bs58check^1.0.11.0.11.0.2
hex^0.1.20.1.20.2.0
meta^1.2.31.7.01.7.0
pointycastle^1.0.21.0.23.4.0
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.3.11.3.1
collection-1.15.01.15.0
convert-2.1.13.0.1
crypto-2.1.53.0.1
typed_data-1.3.01.3.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `0.1.2` on bech32 does not support the stable version `0.2.0`.

Try running dart pub upgrade --major-versions bech32 to update the constraint.

The constraint `^1.0.5` on bip32 does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions bip32 to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.3.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Dart 2.15.0.

28
likes
80
pub points
83%
popularity

A dart Bitcoin library for Flutter. BIP32, BIP39, P2PKH integration.

Homepage

Documentation

API reference

License

MIT (LICENSE)

Dependencies

bech32, bip32, bip39, bs58check, hex, meta, pointycastle

More

Packages that depend on bitcoin_flutter