bitcoin_flutter 2.0.2 copy "bitcoin_flutter: ^2.0.2" to clipboard
bitcoin_flutter: ^2.0.2 copied to clipboard

A dart Bitcoin library for Flutter. BIP32, BIP39, P2PKH integration.

2.0.2 #

  • Add support for optional 'noStrict' parameter in Transaction.fromBuffer

2.0.1 #

  • Add payments/index.dart to lib exports

2.0.0 #

  • Please update your sign function if you use this version. sign now required parameter name
  • Support building a Transaction with a SegWit P2WPKH input
  • Add Address.validateAddress to validate address

1.1.0 #

  • Add PaymentData, P2PKHData to be deprecated, will remove next version
  • Support p2wpkh

1.0.7 #

  • Try catch getter privKey, base58Priv, wif
  • Possible to create a neutered HD Wallet

1.0.6 #

  • Accept non-standard payment

1.0.5 #

  • Add ECPair to index

1.0.4 #

  • Add transaction to index

1.0.3 #

  • Fix bug testnet BIP32

1.0.2 #

  • Add sign and verify for HD Wallet and Wallet

1.0.1 #

  • Add derive and derive path for HD Wallet

1.0.0 #

  • Transaction implementation

0.1.1 #

  • HDWallet from Seed implementation
  • Wallet from WIF implementation
33
likes
40
pub points
70%
popularity

Publisher

unverified uploader

A dart Bitcoin library for Flutter. BIP32, BIP39, P2PKH integration.

Homepage

License

MIT (license)

Dependencies

bech32, bip32, bip39, bs58check, hex, meta, pointycastle

More

Packages that depend on bitcoin_flutter