bezier_chart 1.0.17+1
bezier_chart: ^1.0.17+1 copied to clipboard

Flutter Android iOS Linux macOS web Windows

A beautiful bezier line chart widget for flutter that is highly interactive and configurable.

172
likes
100 / 110
pub points
92 %
popularity

We analyzed this package on Mar 3, 2021, and awarded it 100 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 71 out of 101 API elements (70.3 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: 'List' is deprecated and shouldn't be used. Use a list literal, [], or the List.filled constructor instead.

lib/src/bezier_chart_widget.dart:518:31

    ╷
518 │             tmpMap[key] = new List<double>();
    │                               ^^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/bezier_chart_widget.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
intl^0.16.00.16.10.17.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
meta-1.3.01.3.0
path-1.8.01.8.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.16.0` on intl does not support the stable version `0.17.0`, that was published 27 days ago.

When intl is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions intl to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.3, Flutter 2.0.0, Dart 2.12.0.

172
likes
100
pub points
92%
popularity

Publisher

aeyrium.com

A beautiful bezier line chart widget for flutter that is highly interactive and configurable.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache 2.0 (LICENSE)

Dependencies

flutter, intl

More

Packages that depend on bezier_chart