bethlehem 1.0.24-dev.1 icon indicating copy to clipboard operation
bethlehem: ^1.0.24-dev.1 copied to clipboard

Platformweb

A router for RawDart SPA Development and AngularDart Development.

0
likes
90/ 140
pub points
0%
popularity

We analyzed this package 2 hours ago, and awarded it 90 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

10/10 points: Package has an example

0/10 points: 20% or more of the public API has dartdoc comments

  • 2 out of 71 API elements (2.8 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 1 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Web

These platforms are not supported:

Package not compatible with platform Android

Because:

  • package:bethlehem/bethlehem.dart that imports:
  • package:bethlehem/src/State/RouterState.dart that imports:
  • dart:html

Package not compatible with platform iOS

Because:

  • package:bethlehem/bethlehem.dart that imports:
  • package:bethlehem/src/State/RouterState.dart that imports:
  • dart:html

Package not compatible with platform Windows

Because:

  • package:bethlehem/bethlehem.dart that imports:
  • package:bethlehem/src/State/RouterState.dart that imports:
  • dart:html

Package not compatible with platform Linux

Because:

  • package:bethlehem/bethlehem.dart that imports:
  • package:bethlehem/src/State/RouterState.dart that imports:
  • dart:html

Package not compatible with platform macOS

Because:

  • package:bethlehem/bethlehem.dart that imports:
  • package:bethlehem/src/State/RouterState.dart that imports:
  • dart:html
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 20 issues. Showing the first 2:

INFO: Name source files using lowercase_with_underscores.

To reproduce make sure you are using the lints_core and run dart analyze lib/src/Route/Route.dart

INFO: Name source files using lowercase_with_underscores.

To reproduce make sure you are using the lints_core and run dart analyze lib/src/Router/AngularRouter/AngularRouter.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
angular^6.0.0-alpha6.0.17.0.2
angular_components^1.0.21.0.31.0.3
collection^1.14.131.17.01.17.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-12.0.051.0.0
analyzer-0.40.75.3.1
angular_ast-1.0.12.0.1
angular_compiler-1.0.12.0.2
angular_forms-3.0.04.0.1
args-1.6.02.3.1
async-2.10.02.10.0
build-1.6.22.3.1
build_config-0.4.71.1.1
built_collection-4.3.25.1.1
built_value-7.1.08.4.2
charcode-1.3.11.3.1
checked_yaml-1.0.42.0.1
cli_repl-0.2.30.2.3
cli_util-0.2.00.3.5
code_builder-3.7.04.3.0
convert-2.1.13.1.1
crypto-2.1.53.0.2
csslib-0.16.20.17.2
dart_internal-0.2.60.2.6
dart_style-1.3.102.2.4
file-5.2.16.1.4
fixnum-0.10.111.0.1
glob-1.2.12.1.1
http-0.12.20.13.5
http_parser-3.1.44.0.2
intl-0.16.10.17.0
js-0.6.50.6.5
json_annotation-4.7.04.7.0
logging-0.11.41.1.0
matcher-0.12.130.12.13
meta-1.8.01.8.0
node_interop-1.2.12.1.0
node_io-1.2.02.2.0
observable-0.23.00.24.0
package_config-1.9.32.1.0
package_resolver-1.0.101.0.10
path-1.8.31.8.3
pedantic-1.11.11.11.1
protobuf-1.1.42.1.0
pub_semver-1.4.42.1.3
pubspec_parse-0.1.81.2.1
quiver-2.1.53.1.0
sass-1.32.81.56.2
sass_builder-2.1.32.2.1
source_gen-0.9.10+21.2.6
source_maps-0.10.110.10.11
source_span-1.9.11.9.1
stack_trace-1.11.01.11.0
stream_transform-2.1.02.1.0
string_scanner-1.2.01.2.0
term_glyph-1.2.11.2.1
tuple-1.0.32.0.1
typed_data-1.3.11.3.1
watcher-0.9.7+151.0.2
yaml-2.2.13.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint ^6.0.0-alpha on angular does not support the stable version 7.0.0.

Try running dart pub upgrade --major-versions angular to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint >=2.10.0 <3.0.0) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.21, Dart 2.18.4.

0
likes
90
pub points
0%
popularity

Publisher

unverified uploader

A router for RawDart SPA Development and AngularDart Development.

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.Apache-2.0 (LICENSE)

Dependencies

angular, angular_components, collection

More

Packages that depend on bethlehem