bethlehem 1.0.24-dev.1 icon indicating copy to clipboard operation
bethlehem: ^1.0.24-dev.1 copied to clipboard

Platformweb

A router for RawDart SPA Development and AngularDart Development.

example/bethlehem_example.dart

import 'dart:html';

import 'package:bethlehem/bethlehem.dart' as bethlehem;

void main() {
  var route = bethlehem.Route(routes: {
    'create': HttpRequest.getString('create.html'),
    'add': HttpRequest.getString('add.html'),
    'add/:id <int>': HttpRequest.getString('test1.html'),
    'add/:topic <string>': HttpRequest.getString('test2.html'),
    'add/:id <int>/:topic <string>/:id <int>':
        HttpRequest.getString('test3.html')
  });
  bethlehem.WebView(bethlehem.WebRouter(route));
}
0
likes
90
pub points
0%
popularity

Publisher

unverified uploader

A router for RawDart SPA Development and AngularDart Development.

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.Apache-2.0 (LICENSE)

Dependencies

angular, angular_components, collection

More

Packages that depend on bethlehem