bavest 0.0.7 copy "bavest: ^0.0.7" to clipboard
bavest: ^0.0.7 copied to clipboard

The Bavest SDK for Dart and Flutter provides realtime data for stocks, etfs, mutual fonds.

14
likes
140/ 140
pub points
8%
popularity

We analyzed this package 3 days ago, and awarded it 140 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

211 out of 848 API elements (24.9 %) have documentation comments.

Some symbols that are missing documentation: balance, balance.Balance, balance.Balance.Balance, balance.Balance.balanceData, balance.Balance.Balance.fromJson.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
dio ^5.0.1 5.4.3+1 5.4.3+1
fake_async ^1.3.1 1.3.1 1.3.1
flutter flutter 0.0.0 0.0.0
logger ^2.0.2 2.2.0 2.2.0
memory_cache ^1.2.0 1.2.0 1.2.0
rxdart ^0.27.7 0.27.7 0.27.7
web_socket_channel ^2.3.0 2.4.5 2.4.5
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
crypto - 3.0.3 3.0.3
http_parser - 4.0.2 4.0.2
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
path - 1.9.0 1.9.0
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
web - 0.5.1 0.5.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

14
likes
140
pub points
8%
popularity

Publisher

verified publisherbavest.co

The Bavest SDK for Dart and Flutter provides realtime data for stocks, etfs, mutual fonds.

Homepage

Documentation

API reference

License

MIT (LICENSE)

Dependencies

dio, fake_async, flutter, logger, memory_cache, rxdart, web_socket_channel

More

Packages that depend on bavest