battery 0.3.0+4

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 94

Battery #

pub package

A Flutter plugin to access various information about the battery of the device the app is running on.

Usage #

To use this plugin, add battery as a dependency in your pubspec.yaml file.

Example #

// Import package
import 'package:battery/battery.dart';

// Instantiate it
var battery = Battery();

// Access current battery level
print(await battery.batteryLevel);

// Be informed when the state (full, charging, discharging) changes
_battery.onBatteryStateChanged.listen((BatteryState state) {
  // Do something with new state
});

0.3.0+4 #

  • Update Dart code to conform to current Dart formatter.

0.3.0+3 #

  • Fix batteryLevel usage example in README

0.3.0+2 #

  • Bump the minimum Flutter version to 1.2.0.
  • Add template type parameter to invokeMethod calls.

0.3.0+1 #

  • Log a more detailed warning at build time about the previous AndroidX migration.

0.3.0 #

  • Breaking change. Migrate from the deprecated original Android Support Library to AndroidX. This shouldn't result in any functional changes, but it requires any Android apps using this plugin to also migrate if they're using the original support library.

0.2.3 #

  • Updated mockito dependency to 3.0.0 to get Dart 2 support.
  • Update test package dependency to 1.3.0, and fixed tests to match.

0.2.2 #

  • Updated Gradle tooling to match Android Studio 3.1.2.

0.2.1 #

  • Fixed Dart 2 type error.
  • Removed use of deprecated parameter in example.

0.2.0 #

  • Breaking change. Set SDK constraints to match the Flutter beta release.

0.1.1 #

  • Fixed warnings from the Dart 2.0 analyzer.
  • Simplified and upgraded Android project template to Android SDK 27.
  • Updated package description.

0.1.0 #

  • Breaking change. Upgraded to Gradle 4.1 and Android Studio Gradle plugin 3.0.1. Older Flutter projects need to upgrade their Gradle setup as well in order to use this version of the plugin. Instructions can be found here.

0.0.2 #

  • Add FLT prefix to iOS types.

0.0.1+1 #

  • Updated README

0.0.1 #

  • Initial release

example/README.md

battery_example #

Demonstrates how to use the battery plugin.

Getting Started #

For help getting started with Flutter, view our online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  battery: ^0.3.0+4

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:battery/battery.dart';
  
Version Uploaded Documentation Archive
0.3.0+4 Jun 12, 2019 Go to the documentation of battery 0.3.0+4 Download battery 0.3.0+4 archive
0.3.0+3 Apr 4, 2019 Go to the documentation of battery 0.3.0+3 Download battery 0.3.0+3 archive
0.3.0+2 Apr 2, 2019 Go to the documentation of battery 0.3.0+2 Download battery 0.3.0+2 archive
0.3.0+1 Feb 8, 2019 Go to the documentation of battery 0.3.0+1 Download battery 0.3.0+1 archive
0.3.0 Jan 24, 2019 Go to the documentation of battery 0.3.0 Download battery 0.3.0 archive
0.2.3 Aug 21, 2018 Go to the documentation of battery 0.2.3 Download battery 0.2.3 archive
0.2.2 Jun 1, 2018 Go to the documentation of battery 0.2.2 Download battery 0.2.2 archive
0.2.1 Apr 20, 2018 Go to the documentation of battery 0.2.1 Download battery 0.2.1 archive
0.2.0 Mar 9, 2018 Go to the documentation of battery 0.2.0 Download battery 0.2.0 archive
0.1.1 Jan 11, 2018 Go to the documentation of battery 0.1.1 Download battery 0.1.1 archive

All 14 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
91
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
94
Learn more about scoring.

We analyzed this package on Jun 17, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.3.2
  • pana: 0.12.18
  • Flutter: 1.5.4-hotfix.2

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (1 direct: meta).

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.28.0 <3.0.0
flutter 0.0.0
meta ^1.0.5 1.1.6 1.1.7
Transitive dependencies
collection 1.14.11
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
async ^2.0.8
flutter_test
mockito 3.0.0
test ^1.3.0