battery 1.0.7
battery: ^1.0.7

Flutter Android iOS

Flutter plugin for accessing information about the battery state (full, charging, discharging) on Android and iOS.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

dependencies:
  battery: ^1.0.7

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:battery/battery.dart';
180
likes
90
pub points
95%
popularity

Publisher

flutter.dev

Flutter plugin for accessing information about the battery state (full, charging, discharging) on Android and iOS.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

battery_platform_interface, flutter, meta

More

Packages that depend on battery