barcode_widget 1.5.0
barcode_widget: ^1.5.0
barcode_widget: ^2.0.0-nullsafety.1

Flutter Android iOS web

Barcode generation widget for Flutter with support for standard barcodes.

26
likes
110 / 110
pub points
92 %
popularity

We analyzed this package on Dec 2, 2020, and awarded it 110 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 17 out of 19 API elements (89.5 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
barcode^1.16.01.17.11.17.1
meta^1.1.81.3.0-nullsafety.61.3.0-nullsafety.6
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.51.1.0-nullsafety.5
collection-1.15.0-nullsafety.51.15.0-nullsafety.5
qr-1.3.01.3.0
typed_data-1.3.0-nullsafety.51.3.0-nullsafety.5
vector_math-2.1.0-nullsafety.52.1.0-nullsafety.5

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

26
likes
110
pub points
92%
popularity

Publisher

nfet.net

Barcode generation widget for Flutter with support for standard barcodes.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache 2.0 (LICENSE)

Dependencies

barcode, flutter, meta

More

Packages that depend on barcode_widget