barcode_widget 1.5.0

Flutter Android iOS web

Barcode generation widget for Flutter with support for standard barcodes.

Changelog #

1.5.0 #

  • Add textPadding parameter

1.4.0 #

  • Allow Uint8List data barcodes

1.3.0 #

  • Add errorBuilder to BarcodeWidget
  • Update dependencies

1.2.4 #

  • Update example

1.2.3 #

  • Fix 2D Codes pixel gap

1.2.2 #

  • Fix GestureDetector doesn't work

1.2.1 #

  • Fix README

1.2.0 #

  • Implement text alignment
  • Update dependency to barcode ^1.3.0
  • Fix text position

1.1.0 #

  • Add error messages
  • Rewrite example
  • Create gh-pages with Flutter Demo
  • Implement Widget update

1.0.0 #

  • Initial release.
17
likes
110
pub points
92%
popularity

Publisher

nfet.net

Barcode generation widget for Flutter with support for standard barcodes.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache 2.0 (LICENSE)

Dependencies

barcode, flutter, meta

More

Packages that depend on barcode_widget