at_app 0.1.2 icon indicating copy to clipboard operation
at_app: ^0.1.2 copied to clipboard

A command line tool to help developers build an @ platform application.

7
likes
90/ 130
pub points
19%
popularity

We analyzed this package 30 days ago, and awarded it 90 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
20 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

  • Found example at: example/example.md

10/10 points: 20% or more of the public API has dartdoc comments

  • 13 out of 25 API elements (52.0 %) have documentation comments.
icon indicating section status
Support multiple platforms
10 / 20icon to trigger folding of the section

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:at_app/at_app.dart that imports:
  • package:at_client_mobile/at_client_mobile.dart that imports:
  • package:at_client_mobile/src/keychain_manager.dart that imports:
  • package:flutter_keychain/flutter_keychain.dart that declares support for platforms: Android, iOS.
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
at_client_mobile^2.0.32.0.43.1.3
at_onboarding_flutter^2.1.22.1.33.1.2
at_utils^2.0.42.0.43.0.2
dotenv^3.0.03.0.03.0.0
flutterflutter0.0.00.0.0
flutter_toolsflutter0.0.00.0.0
path_provider^2.0.22.0.82.0.8
version^2.0.02.0.02.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-30.0.032.0.0
analyzer-2.7.03.0.0
archive-3.1.63.1.6
args-2.3.02.3.0
asn1lib-1.0.31.0.3
async-2.8.22.8.2
at_backupkey_flutter-2.0.13.1.2
at_base2e15-1.0.01.0.0
at_client-2.0.43.0.7
at_commons-2.0.53.0.2
at_lookup-2.0.53.0.5
at_persistence_secondary_server-2.0.63.0.11
at_persistence_spec-2.0.32.0.3
at_server_status-1.0.21.0.3
at_utf7-1.0.01.0.0
boolean_selector-2.1.02.1.0
browser_launcher-1.0.01.0.0
built_collection-5.1.15.1.1
built_value-8.1.38.1.3
characters-1.2.01.2.0
charcode-1.3.11.3.1
cli_util-0.3.50.3.5
clock-1.1.01.1.0
collection-1.15.01.15.0
completion-1.0.01.0.0
convert-3.0.13.0.1
coverage-1.0.31.0.4
cron-0.3.20.4.0
crypto-3.0.13.0.1
crypton-2.0.32.0.3
csslib-0.17.10.17.1
dds-2.1.42.1.7
devtools_shared-2.7.02.9.2
dwds-11.4.011.5.1
encrypt-5.0.15.0.1
fake_async-1.2.01.2.0
ffi-1.1.21.1.2
file-6.1.26.1.2
file_picker-3.0.44.3.0
fixnum-1.0.01.0.0
flutter_keychain-2.1.02.1.0
flutter_plugin_android_lifecycle-2.0.52.0.5
flutter_qr_reader-1.0.51.0.5
flutter_template_images-4.0.04.0.0
flutter_web_plugins-0.0.00.0.0
frontend_server_client-2.1.22.1.2
glob-2.0.22.0.2
hive-2.0.52.0.5
html-0.15.00.15.0
http-0.13.40.13.4
http_multi_server-3.0.13.0.1
http_parser-4.0.04.0.0
internet_connection_checker-0.0.1+30.0.1+3
intl-0.17.00.17.0
io-1.0.31.0.3
js-0.6.30.6.4
json_rpc_2-3.0.13.0.1
logging-1.0.21.0.2
matcher-0.12.110.12.11
meta-1.7.01.7.0
mime-1.0.11.0.1
multicast_dns-0.3.10.3.1
mustache_template-2.0.02.0.0
native_stack_traces-0.4.30.4.3
package_config-2.0.22.0.2
path-1.8.01.8.1
path_provider_android-2.0.112.0.11
path_provider_ios-2.0.72.0.7
path_provider_linux-2.1.42.1.4
path_provider_macos-2.0.42.0.4
path_provider_platform_interface-2.0.12.0.1
path_provider_windows-2.0.42.0.4
permission_handler-8.3.08.3.0
permission_handler_platform_interface-3.7.03.7.0
petitparser-4.4.04.4.0
pin_code_fields-7.3.07.3.0
platform-3.0.23.1.0
plugin_platform_interface-2.0.22.0.2
pointycastle-3.4.03.4.0
pool-1.5.01.5.0
process-4.2.44.2.4
pub_semver-2.1.02.1.0
share-2.0.42.0.4
shelf-1.1.41.2.0
shelf_packages_handler-3.0.03.0.0
shelf_proxy-1.0.11.0.1
shelf_static-1.1.01.1.0
shelf_web_socket-1.0.11.0.1
sky_engine-0.0.990.0.99
source_map_stack_trace-2.1.02.1.0
source_maps-0.10.100.10.10
source_span-1.8.11.8.1
sse-4.1.04.1.0
stack_trace-1.10.01.10.0
stream_channel-2.1.02.1.0
string_scanner-1.1.01.1.0
sync_http-0.3.00.3.0
term_glyph-1.2.01.2.0
test_api-0.4.30.4.9
test_core-0.4.20.4.11
typed_data-1.3.01.3.0
url_launcher-6.0.176.0.17
url_launcher_android-6.0.136.0.13
url_launcher_ios-6.0.136.0.13
url_launcher_linux-2.0.22.0.2
url_launcher_macos-2.0.22.0.2
url_launcher_platform_interface-2.0.42.0.4
url_launcher_web-2.0.52.0.5
url_launcher_windows-2.0.22.0.2
usage-4.0.24.0.2
uuid-3.0.53.0.5
vector_math-2.1.12.1.1
vm_service-7.3.08.1.0
vm_snapshot_analysis-0.7.00.7.0
watcher-1.0.11.0.1
web_socket_channel-2.1.02.1.0
webdriver-3.0.03.0.0
webkit_inspection_protocol-1.0.01.0.0
webview_flutter-2.8.03.0.0
webview_flutter_android-2.8.22.8.2
webview_flutter_platform_interface-1.8.01.8.0
webview_flutter_wkwebview-2.7.12.7.1
win32-2.3.32.3.3
xdg_directories-0.2.00.2.0
xml-5.3.15.3.1
yaml-3.1.03.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^2.0.3` on at_client_mobile does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions at_client_mobile to update the constraint.

The constraint `^2.1.2` on at_onboarding_flutter does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions at_onboarding_flutter to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Null safety support has one or more issues.

Package is not null safe

Because:

  • at_app that depends on:
  • flutter_tools that depends on:
  • flutter_template_images that doesn't opt in to null safety
For more information

Try running dart pub outdated --mode=null-safety. Be sure to read the migration guide.

Analysed with Pana 0.21.4, Flutter 2.8.0, Dart 2.15.0.

7
likes
90
pub points
19%
popularity

Publisher

shield icon for verified publishersatsign.org

A command line tool to help developers build an @ platform application.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

at_client_mobile, at_onboarding_flutter, at_utils, dotenv, flutter, flutter_tools, path_provider, version

More

Packages that depend on at_app