ar_widget 0.0.4 copy "ar_widget: ^0.0.4" to clipboard
ar_widget: ^0.0.4 copied to clipboard

Widget in the AR World

1
likes
130/ 140
pub points
19%
popularity

We analyzed this package 2 days ago, and awarded it 130 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

2 out of 9 API elements (22.2 %) have documentation comments.

Some symbols that are missing documentation: ar_widget, ar_widget.ARWidget.canvasHeight, ar_widget.ARWidget.canvasWidth, ar_widget.ARWidget.child, ar_widget.ArWidgetPlugin.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:ar_widget/ar_widget.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:ar_widget/ar_widget.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:ar_widget/ar_widget.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:ar_widget/ar_widget.dart that declares support for platforms: Android, iOS.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:ar_widget/ar_widget.dart that imports:
  • package:ar_widget/src/ar_widget.dart that imports:
  • package:ar_widget/src/arkit_widget.dart that imports:
  • package:arkit_plugin/arkit_plugin.dart that declares support for platforms: iOS.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
arkit_plugin any 1.0.7 1.0.7
flutter flutter 0.0.0 0.0.0
json_annotation any 4.8.1 4.8.1
permission_handler any 11.3.0 11.3.0
plugin_platform_interface any 2.1.8 2.1.8
vector_math any 2.1.4 2.1.4
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
flutter_web_plugins - 0.0.0 0.0.0
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
permission_handler_android - 12.0.5 12.0.5
permission_handler_apple - 9.4.0 9.4.0
permission_handler_html - 0.1.1 0.1.1
permission_handler_platform_interface - 4.2.0 4.2.0
permission_handler_windows - 0.2.1 0.2.1
sky_engine - 0.0.99 0.0.99

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.0, Flutter 3.19.0, Dart 3.3.0.

Check the analysis log for details.