appkit_ui_element_colors 1.0.0 copy "appkit_ui_element_colors: ^1.0.0" to clipboard
appkit_ui_element_colors: ^1.0.0 copied to clipboard

PlatformmacOS

A Flutter plugin that exposes AppKit’s “UI Element Colors.”

0
likes
130/ 140
pub points
92%
popularity

We analyzed this package 32 hours ago, and awarded it 130 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

91 out of 106 API elements (85.8 %) have documentation comments.

Some symbols that are missing documentation: appkit_ui_element_colors, appkit_ui_element_colors.AppkitUiElementColors, ns_appearance_name, ns_color_component, ns_color_space.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 1 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ macOS

These platforms are not supported:

Package does not support platform `Android`.

Because:

  • package:appkit_ui_element_colors/appkit_ui_element_colors.dart that declares support for platforms: macOS.
Package does not support platform `iOS`.

Because:

  • package:appkit_ui_element_colors/appkit_ui_element_colors.dart that declares support for platforms: macOS.
Package does not support platform `Windows`.

Because:

  • package:appkit_ui_element_colors/appkit_ui_element_colors.dart that declares support for platforms: macOS.
Package does not support platform `Linux`.

Because:

  • package:appkit_ui_element_colors/appkit_ui_element_colors.dart that declares support for platforms: macOS.
Package does not support platform `Web`.

Because:

  • package:appkit_ui_element_colors/appkit_ui_element_colors.dart that declares support for platforms: macOS.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
equatable ^2.0.5 2.0.5 2.0.5
flutter flutter 0.0.0 0.0.0
plugin_platform_interface ^2.0.2 2.1.8 2.1.8
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.0, Flutter 3.19.0, Dart 3.3.0.

Check the analysis log for details.

0
likes
130
pub points
92%
popularity

Publisher

unverified uploader

A Flutter plugin that exposes AppKit’s “UI Element Colors.”

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

equatable, flutter, plugin_platform_interface

More

Packages that depend on appkit_ui_element_colors