appcenterpublisher 0.2.0

  • Readme
  • Changelog
  • Installing
  • 48

Build status

App Center Publisher #

Dart tooling to upload and distribute app to MS Appcenter by using the rest Appcenter Rest API .

Installation #

Run pub global activate appcenterpublisher

In order to update the tool use the same pub global activate command

Usage #

Preconditions:

  1. Create an Api token on App Center Read more about how to create such a token here.

  2. Create a yaml file containing the config. For more info see the example config.

  3. Have a binary of the app (e.g. .ipa or .apk) located on the machine from where you want to run this tool.

Run appcenterpublisher publish --apiToken <appcenter apitoken> --binary <path to binary> --config <path to config yaml file>

Limitations #

The tool is not yet complete in the future I will add the following to the tool:

  • Distribute the app to multiple distribution groups at once
  • Add more configuration options:
    • Notify testers (now on by default)
    • Mandatory update (now on by default)

0.2.0 #

  • Breaking change: Add ability to upload multiple apps per config yaml

0.1.1 #

  • Fix analyzer issues introduced by Dart sdk 2.7

0.1.0+1 #

  • Minor fixes

0.1.0 #

  • Initial version

Use this package as an executable

1. Install it

You can install the package from the command line:


$ pub global activate appcenterpublisher

2. Use it

The package has the following executables:


$ appcenterpublisher
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
48
Learn more about scoring.

We analyzed this package on Mar 31, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.6

Health suggestions

Format bin/main.dart.

Run dartfmt to format bin/main.dart.

Format lib/src/api/commit_upload.dart.

Run dartfmt to format lib/src/api/commit_upload.dart.

Format lib/src/api/create_upload_url.dart.

Run dartfmt to format lib/src/api/create_upload_url.dart.

Fix additional 13 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/src/api/distribute_to_group.dart (Run dartfmt to format lib/src/api/distribute_to_group.dart.)
  • lib/src/api/upload_binary.dart (Run dartfmt to format lib/src/api/upload_binary.dart.)
  • lib/src/api_operation_data.dart (Run dartfmt to format lib/src/api_operation_data.dart.)
  • lib/src/api_operation_data.g.dart (Run dartfmt to format lib/src/api_operation_data.g.dart.)
  • lib/src/model/distribution_group.dart (Run dartfmt to format lib/src/model/distribution_group.dart.)
  • lib/src/model/distribution_group.g.dart (Run dartfmt to format lib/src/model/distribution_group.g.dart.)
  • lib/src/model/release_info.dart (Run dartfmt to format lib/src/model/release_info.dart.)
  • lib/src/model/release_info.g.dart (Run dartfmt to format lib/src/model/release_info.g.dart.)
  • lib/src/model/run_data.dart (Run dartfmt to format lib/src/model/run_data.dart.)
  • lib/src/model/run_data.g.dart (Run dartfmt to format lib/src/model/run_data.g.dart.)
  • lib/src/parse_yaml.dart (Run dartfmt to format lib/src/parse_yaml.dart.)
  • lib/src/publish_app_command.dart (Run dartfmt to format lib/src/publish_app_command.dart.)
  • lib/src/upload_orchestrator.dart (Run dartfmt to format lib/src/upload_orchestrator.dart.)

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

exitCode: 255 stdout: parsing /dart-sdk/lib/async/async.dart... parsing /dart-sdk/lib/collection/collection.dart... parsing /dart-sdk/lib/internal/internal.dart... parsing /dart-sdk/lib/convert/convert.dart... parsing /dart-sdk/lib/typed_data/typed_data.dart... parsing /dart-sdk/lib/core/core.dart... parsing /dart-sdk/lib/math/math.dart... parsing /dart-sdk/lib/developer/developer.dart... parsing /dart-sdk/lib/isolate/isolate.dart... parsing /dart-sdk/lib/ffi/ffi.dart... parsing /dart-sdk/lib/html/dart2js/html_dart2js.dart... parsing /dart-sdk/lib/html/html_common/html_common_dart2js.dart... parsing /dart-sdk/lib/web_gl/dart2js/web_gl_dart2js.dart... parsing /dart-sdk/lib/_internal/js_runtime/lib/native_typed_data.dart... parsing /dart-sdk/lib/_internal/js_runtime/lib/interceptors.dart... parsing /dart-sdk/lib/_internal/js_runtime/lib/shared/embedded_names.dart... parsing /dart-sdk/lib/_internal/js_runtime/lib/js_helper.dart... parsing /dart-sdk/lib/_internal/js_runtime/lib/foreign_helper.dart... parsing /dart-sdk/lib/_internal/js_runtime/lib/js_names.dart... parsing /dart-sdk/lib/_internal/js_runtime/lib/rti.dart... parsing /dart-sdk/lib/_internal/js_runtime/lib/shared/recipe_syntax.dart... parsing /dart-sdk/lib/js_util/dart2js/js_util_dart2js.dart... parsing /dart-sdk/lib/html/html_common/metadata.dart... parsing /dart-sdk/lib/indexed_db/dart2js/indexed_db_dart2js.dart... parsing /dart-sdk/lib/svg/dart2js/svg_dart2js.dart... parsing /dart-sdk/lib/web_audio/dart2js/web_audio_dart2js.dart... parsing /dart-sdk/lib/web_sql/dart2js/web_sql_dart2js.dart... parsing /dart-sdk/lib/_http/http.dart... parsing /dart-sdk/lib/io/io.dart... parsing /dart-sdk/lib/js/dart2js/js_dart2js.dart... parsing /dart-sdk/lib/js/_js.dart... parsing /dart-sdk/lib/mirrors/mirrors.dart... parsing /dart-sdk/lib/html/dartium/nativewrappers.dart... parsing /dart-sdk/lib/cli/cli.dart... parsing /dart-sdk/lib/wasm/wasm.dart... parsing /dart-sdk/lib/_internal/js_runtime/lib/js_primitives.dart... parsing /dart-sdk/lib/_internal/js_runtime/lib/shared/async_await_error_codes.dart... Initialized dartdoc with 37 libraries in 29.4 seconds documenting appcenterpublisher Validating docs... Documented 0 public libraries in 1.4 seconds stderr: Documenting appcenterpublisher... warning: dartdoc generated a broken link to: %22https:/docs.microsoft.com/en-us/appcenter/distribution/uploading#uploading-the-package%22,, linked to from package-appcenterpublisher: file:///tmp/pub-dartlang-dartdocLAKHXV/pkg found 1 warning and 0 errors Unhandled exception: dartdoc could not find any libraries to document #0 Dartdoc.generateDocs (package:dartdoc/dartdoc.dart:196:7)

Maintain an example.

None of the files in the package's example/ directory matches known example patterns.

Common filename patterns include main.dart, example.dart, and appcenterpublisher.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.6.0 <3.0.0
args ^1.5.2 1.6.0
functional_data ^0.2.3 0.2.3
http ^0.12.0+2 0.12.0+4
http_parser ^3.1.3 3.1.4
json_annotation ^3.0.0 3.0.1
meta ^1.1.7 1.1.8
sum_types ^0.2.1 0.2.1+2
yaml ^2.2.0 2.2.0
Transitive dependencies
async 2.4.1
charcode 1.1.3
collection 1.14.12
path 1.6.4
pedantic 1.9.0
source_span 1.7.0
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
Dev dependencies
build_runner ^1.7.1
dependency_validator ^1.0.0
functional_data_generator ^0.2.5
json_serializable ^3.2.0
mockito ^4.1.1
sum_types_generator ^0.2.1
test ^1.9.1