api_request 1.0.9 copy "api_request: ^1.0.9" to clipboard
api_request: ^1.0.9 copied to clipboard

api request for handle call api. every request is an action has execute method.

18
likes
130/ 140
pub points
69%
popularity

We analyzed this package 3 days ago, and awarded it 130 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

251 out of 429 API elements (58.5 %) have documentation comments.

Some symbols that are missing documentation: api_request, api_request.ActionErrorType, api_request.ActionErrorType.ActionErrorType, api_request.ActionRequestError, api_request.ActionRequestError.ActionRequestError.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

INFO: An uninitialized field should have an explicit type annotation.

lib/src/actions/request_action.dart:45:7

   ╷
45 │   var _dataMap;
   │       ^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/actions/request_action.dart

lib/src/api_resource.dart doesn't match the Dart formatter.

To format your files run: dart format .

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
dartz ^0.10.1 0.10.1 0.10.1
dio ^5.4.0 5.4.3+1 5.4.3+1
flutter flutter 0.0.0 0.0.0
rich_console ^1.0.7+1 1.0.7+2 1.0.7+2
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
http_parser - 4.0.2 4.0.2
intl - 0.19.0 0.19.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.12.0 1.15.0
path - 1.9.0 1.9.0
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.

18
likes
130
pub points
69%
popularity

Publisher

verified publisherm-it.dev

api request for handle call api. every request is an action has execute method.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

dartz, dio, flutter, rich_console

More

Packages that depend on api_request