ann_quill_html_editor 2.3.0+2 copy "ann_quill_html_editor: ^2.3.0+2" to clipboard
ann_quill_html_editor: ^2.3.0+2 copied to clipboard

HTML rich text editor for Android, iOS, and Web, it is built with the powerful Quill Js library. Which is an open source WYSIWYG editor built for the modern web.

2
likes
110/ 140
pub points
68%
popularity

We analyzed this package 29 hours ago, and awarded it 110 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://github.com/the-airbender/ann_quill_html_editor was unreachable. Make sure that the website is reachable via HEAD requests.

Repository URL doesn't exist.

At the time of the analysis https://github.com/the-airbender/ann_quill_html_editor was unreachable. Make sure that the website is reachable via HEAD requests.

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: ann_quill_html_editor,
    • contains a version property, and,
    • does not contain a publish_to property.

Unable to access git repository: Failed to run remote show origin.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

113 out of 113 API elements (100.0 %) have documentation comments.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Web

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:ann_quill_html_editor/ann_quill_html_editor.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `Linux`.

Because:

  • package:ann_quill_html_editor/ann_quill_html_editor.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `macOS`.

Because:

  • package:ann_quill_html_editor/ann_quill_html_editor.dart that declares support for platforms: Android, iOS, Web.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:ann_quill_html_editor/ann_quill_html_editor.dart that imports:
  • package:ann_quill_html_editor/src/tool_bar.dart that imports:
  • package:ann_quill_html_editor/src/widgets/input_url_widget.dart that imports:
  • package:ann_quill_html_editor/src/widgets/el_tooltip/el_tooltip.dart that imports:
  • package:ann_quill_html_editor/src/widgets/webviewx/src/webviewx_plus.dart that imports:
  • package:ann_quill_html_editor/src/widgets/webviewx/src/view/view.dart that imports:
  • package:ann_quill_html_editor/src/widgets/webviewx/src/view/impl/io.dart that imports:
  • package:ann_quill_html_editor/src/widgets/webviewx/src/view/impl/mobile.dart that imports:
  • package:webview_flutter_wkwebview/webview_flutter_wkwebview.dart that declares support for platforms: iOS.
Package does not support platform `iOS`.

Because:

  • package:ann_quill_html_editor/ann_quill_html_editor.dart that imports:
  • package:ann_quill_html_editor/src/tool_bar.dart that imports:
  • package:ann_quill_html_editor/src/widgets/input_url_widget.dart that imports:
  • package:ann_quill_html_editor/src/widgets/el_tooltip/el_tooltip.dart that imports:
  • package:ann_quill_html_editor/src/widgets/webviewx/src/webviewx_plus.dart that imports:
  • package:ann_quill_html_editor/src/widgets/webviewx/src/view/view.dart that imports:
  • package:ann_quill_html_editor/src/widgets/webviewx/src/view/impl/io.dart that imports:
  • package:ann_quill_html_editor/src/widgets/webviewx/src/view/impl/mobile.dart that imports:
  • package:webview_flutter_android/webview_flutter_android.dart that declares support for platforms: Android.
Package not compatible with platform Web

Because:

  • package:ann_quill_html_editor/ann_quill_html_editor.dart that imports:
  • package:ann_quill_html_editor/src/tool_bar.dart that imports:
  • package:ann_quill_html_editor/src/widgets/image_picker.dart that imports:
  • package:file_picker/file_picker.dart that imports:
  • package:file_picker/src/file_picker.dart that imports:
  • package:file_picker/src/linux/file_picker_linux.dart that imports:
  • package:file_picker/src/utils.dart that imports:
  • dart:io
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 18 issues. Showing the first 2:

INFO: Dangling library doc comment.

lib/src/widgets/el_tooltip/src/element_box.dart:1:1

  ╷
1 │ /// ElementBox class is used to represent an element's offset information.
  │ ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/widgets/el_tooltip/src/element_box.dart

INFO: Dangling library doc comment.

lib/src/widgets/el_tooltip/src/enum/el_tooltip_position.dart:1:1

  ╷
1 │ ┌ /// The [ElTooltipPosition] enum is used to specify the desired position of the tooltip
2 │ │ ///
3 │ └ /// The tooltips can be displayed in the following positions:
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/widgets/el_tooltip/src/enum/el_tooltip_position.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
file_picker ^5.2.9 5.5.0 8.0.3
flutter flutter 0.0.0 0.0.0
flutter_web_plugins flutter 0.0.0 0.0.0
http ^0.13.6 0.13.6 1.2.1
path ^1.8.2 1.9.0 1.9.0
pointer_interceptor ^0.9.3+5 0.9.3+7 0.10.1+1
uuid ^3.0.7 3.0.7 4.4.0
webview_flutter ^4.4.2 4.8.0 4.8.0
webview_flutter_android ^3.12.1 3.16.2 3.16.2
webview_flutter_platform_interface ^2.6.0 2.10.0 2.10.0
webview_flutter_wkwebview ^3.9.4 3.13.1 3.13.1
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
crypto - 3.0.3 3.0.3
ffi - 2.1.2 2.1.2
flutter_plugin_android_lifecycle - 2.0.19 2.0.19
http_parser - 4.0.2 4.0.2
material_color_utilities - 0.8.0 0.11.1
meta - 1.12.0 1.15.0
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
win32 - 5.5.1 5.5.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `^5.2.9` on file_picker does not support the stable version `6.0.0`.

Try running dart pub upgrade --major-versions file_picker to update the constraint.

The constraint `^0.13.6` on http does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.

2
likes
110
pub points
68%
popularity

Publisher

verified publisheranline.cn

HTML rich text editor for Android, iOS, and Web, it is built with the powerful Quill Js library. Which is an open source WYSIWYG editor built for the modern web.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

file_picker, flutter, flutter_web_plugins, http, path, pointer_interceptor, uuid, webview_flutter, webview_flutter_android, webview_flutter_platform_interface, webview_flutter_wkwebview

More

Packages that depend on ann_quill_html_editor