ann_html_editor 2.6.0+3 copy "ann_html_editor: ^2.6.0+3" to clipboard
ann_html_editor: ^2.6.0+3 copied to clipboard

HTML rich text editor for Android, iOS, and Web, using the Summernote library. Enhanced with highly customizable widget-based controls, bug fixes, callbacks, dark mode, and more. fork from https://git [...]

1
likes
70/ 140
pub points
42%
popularity

We analyzed this package 11 hours ago, and awarded it 70 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too long.

Search engines display only the first part of the description. Try to keep the value of the description field in your package's pubspec.yaml file between 60 and 180 characters.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

217 out of 369 API elements (58.8 %) have documentation comments.

Some symbols that are missing documentation: ann_html_editor, ann_html_editor.ToolbarWidget.callbacks, ann_html_editor.ToolbarWidget.htmlToolbarOptions, ann_html_editor.ToolbarWidgetState.disable, ann_html_editor.ToolbarWidgetState.enable.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Web

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:ann_html_editor/ann_html_editor.dart that imports:
  • package:flutter_inappwebview/flutter_inappwebview.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:ann_html_editor/ann_html_editor.dart that imports:
  • package:flutter_inappwebview/flutter_inappwebview.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:ann_html_editor/ann_html_editor.dart that imports:
  • package:flutter_inappwebview/flutter_inappwebview.dart that declares support for platforms: Android, iOS.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:ann_html_editor/ann_html_editor.dart that imports:
  • package:ann_html_editor/utils/options.dart that imports:
  • package:file_picker/file_picker.dart that imports:
  • package:file_picker/src/file_picker.dart that imports:
  • package:file_picker/src/windows/file_picker_windows.dart that imports:
  • package:win32/winrt.dart that declares support for platforms: Windows.
Package does not support platform `iOS`.

Because:

  • package:ann_html_editor/ann_html_editor.dart that imports:
  • package:ann_html_editor/utils/options.dart that imports:
  • package:file_picker/file_picker.dart that imports:
  • package:file_picker/src/file_picker.dart that imports:
  • package:file_picker/src/windows/file_picker_windows.dart that imports:
  • package:win32/winrt.dart that declares support for platforms: Windows.
Package not compatible with platform Web

Because:

  • package:ann_html_editor/ann_html_editor.dart that imports:
  • package:ann_html_editor/utils/options.dart that imports:
  • package:file_picker/file_picker.dart that imports:
  • package:file_picker/src/file_picker.dart that imports:
  • package:file_picker/src/linux/file_picker_linux.dart that imports:
  • package:file_picker/src/utils.dart that imports:
  • dart:io
failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

Found 21 issues. Showing the first 2:

ERROR: The getter 'headline6' isn't defined for the type 'TextTheme'.

lib/src/widgets/toolbar_widget.dart:1123:68

     ╷
1123 │                                 style: Theme.of(context).textTheme.headline6),
     │                                                                    ^^^^^^^^^
     ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/widgets/toolbar_widget.dart

ERROR: The getter 'bodyText1' isn't defined for the type 'TextTheme'.

lib/src/widgets/toolbar_widget.dart:1875:56

     ╷
1875 │                                                       .bodyText1
     │                                                        ^^^^^^^^^
     ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/widgets/toolbar_widget.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
file_picker 5.2.9 5.2.9 8.0.3
flex_color_picker ^3.3.0 3.5.0 3.5.0
flutter flutter 0.0.0 0.0.0
flutter_inappwebview ^5.8.0 5.8.0 6.0.0
flutter_keyboard_visibility ^5.4.1 5.4.1 6.0.0
meta >=1.0.0 <2.0.0 1.12.0 1.15.0
numberpicker ^2.1.2 2.1.2 2.1.2
pedantic ^1.11.1 1.11.1 1.11.1
pointer_interceptor ^0.9.3+5 0.9.3+7 0.10.1+1
visibility_detector ^0.4.0+2 0.4.0+2 0.4.0+2
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
ffi - 2.1.2 2.1.2
flex_seed_scheme - 2.0.0 2.0.0
flutter_keyboard_visibility_linux - 1.0.0 1.0.0
flutter_keyboard_visibility_macos - 1.0.0 1.0.0
flutter_keyboard_visibility_platform_interface - 2.0.0 2.0.0
flutter_keyboard_visibility_web - 2.0.0 2.0.0
flutter_keyboard_visibility_windows - 1.0.0 1.0.0
flutter_plugin_android_lifecycle - 2.0.19 2.0.19
flutter_web_plugins - 0.0.0 0.0.0
infinite_listview - 1.1.0 1.1.0
material_color_utilities - 0.8.0 0.11.1
path - 1.9.0 1.9.0
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4
win32 - 3.1.4 5.5.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `5.2.9` on file_picker does not support the stable version `5.2.10`.

Try running dart pub upgrade --major-versions file_picker to update the constraint.

The constraint `^5.8.0` on flutter_inappwebview does not support the stable version `6.0.0`.

Try running dart pub upgrade --major-versions flutter_inappwebview to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.

1
likes
70
pub points
42%
popularity

Publisher

verified publisheranline.cn

HTML rich text editor for Android, iOS, and Web, using the Summernote library. Enhanced with highly customizable widget-based controls, bug fixes, callbacks, dark mode, and more. fork from https://github.com/tneotia/html-editor-enhanced fix iOS build error and dependency conflict, optimize custom media embed features

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

file_picker, flex_color_picker, flutter, flutter_inappwebview, flutter_keyboard_visibility, meta, numberpicker, pedantic, pointer_interceptor, visibility_detector

More

Packages that depend on ann_html_editor