angular_components 0.13.0+1

The official Material Design components for AngularDart. Used at Google in production apps.

12
likes
35 / 110
pub points
94 %
popularity

We analyzed this package on Sep 25, 2020, and awarded it 35 pub points (of a possible 110):

Follow Dart file conventions
5 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://webdev.dartlang.org/components was unreachable.

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 link is insecure.

README.md:65:22

   ╷
65 │ component's provided <a href="http://sass-lang.com/guide#topic-6">Sass mixins</a>.</p>
   │                      ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 2939 out of 5732 API elements (51.3 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime native

Because:

  • package:angular_components/angular_components.dart that imports:
  • package:angular_components/theme/module.dart that imports:
  • package:angular/angular.dart that imports:
  • package:angular/src/platform/browser/tools/tools.dart that imports:
  • package:angular/src/platform/browser/tools/common_tools.dart that imports:
  • package:angular/src/core/linker/component_factory.dart that imports:
  • package:angular/src/core/linker/view_ref.dart that imports:
  • dart:html
Pass static analysis
0 / 30

0/30 points: code has no errors, warnings, lints, or formatting issues

Found 104 issues. Showing the first 2:

ERROR: Evaluation of this constant expression throws an exception.

lib/laminate/ruler/dom_ruler.dart:49:38

   ╷
49 │       return Future<Rectangle>.value(const Rectangle(0, 0, 0, 0));
   │                                      ^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/laminate/ruler/dom_ruler.dart

ERROR: Evaluation of this constant expression throws an exception.

lib/laminate/ruler/dom_ruler.dart:69:52

   ╷
69 │       return Stream<Rectangle>.fromIterable(const [Rectangle(0, 0, 0, 0)]);
   │                                                    ^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/laminate/ruler/dom_ruler.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
angular^5.3.05.3.15.3.1
angular_forms^2.1.02.1.22.1.4
async^2.1.02.4.22.4.2
build>=0.11.1 <2.0.01.5.01.5.0
build_config>=0.2.6 <0.5.00.4.20.4.2
built_collection^4.0.04.3.24.3.2
collection^1.14.101.14.131.14.13
fixnum^0.10.70.10.110.10.11
intl>=0.14.0 <0.17.00.15.80.16.1
js^0.6.10.6.20.6.2
logging^0.11.20.11.40.11.4
meta^1.0.41.2.31.2.3
observable^0.22.20.22.20.22.2
protobuf^0.13.60.13.16+11.0.1
quiver>=0.24.0 <3.0.02.1.32.1.3
sass_builder^2.0.22.1.32.1.3
Transitive dependencies
PackageConstraintCompatibleLatest
analyzer-0.35.40.40.3
angular_ast-0.5.90.5.11
angular_compiler-0.4.30.4.5
args-1.6.01.6.0
built_value-7.1.07.1.0
charcode-1.1.31.1.3
checked_yaml-1.0.21.0.2
cli_repl-0.2.0+10.2.0+1
code_builder-3.4.13.4.1
convert-2.1.12.1.1
crypto-2.1.52.1.5
csslib-0.14.6+10.16.2
dart_internal-0.1.100.1.10
dart_style-1.2.41.3.7
front_end-0.1.140.1.29
glob-1.2.01.2.0
http-0.12.20.12.2
http_parser-3.1.43.1.4
json_annotation-3.1.03.1.0
kernel-0.3.140.3.29
matcher-0.12.90.12.9
node_interop-1.1.11.1.1
node_io-1.1.11.1.1
package_config-1.9.31.9.3
package_resolver-1.0.101.0.10
pedantic-1.9.21.9.2
pub_semver-1.4.41.4.4
pubspec_parse-0.1.50.1.5
sass-1.26.111.26.11
source_gen-0.9.4+40.9.7+1
source_maps-0.10.90.10.9
source_span-1.7.01.7.0
stack_trace-1.9.51.9.5
stream_transform-1.2.01.2.0
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
tuple-1.0.31.0.3
typed_data-1.2.01.2.0
watcher-0.9.7+150.9.7+15
yaml-2.2.12.2.1

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.13.6` on protobuf does not support the latest published version `1.0.1`

pubspec.yaml:25:13

   ╷
25 │   protobuf: ^0.13.6
   │             ^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

12
likes
35
pub points
94%
popularity

The official Material Design components for AngularDart. Used at Google in production apps.

Homepage

Documentation

Documentation
API reference

Uploaders

nshahan@google.com
kevmoo@google.com

License

BSD (LICENSE)

Dependencies

angular, angular_forms, async, build, build_config, built_collection, collection, fixnum, intl, js, logging, meta, observable, protobuf, quiver, sass_builder

More

Packages that depend on angular_components