angel_websocket 2.0.3

Dart native js
Flutter Android iOS web

Support for using pkg:angel_client with WebSockets. Designed for Angel.

1
likes
100 / 110
pub points
77 %
popularity

We analyzed this package on Aug 14, 2020, and awarded it 100 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 120 out of 199 API elements (60.3 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 125 issues. Showing the first 2:

INFO: Don't type annotate initializing formals.

lib/angel_websocket.dart:9:19

  ╷
9 │   WebSocketEvent({String this.eventName, this.data});
  │                   ^^^^^^
  ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/angel_websocket.dart

INFO: Unnecessary new keyword.

lib/angel_websocket.dart:11:48

   ╷
11 │     factory WebSocketEvent.fromJson(Map data) => new WebSocketEvent(
   │ ┌────────────────────────────────────────────────^
12 │ │       eventName: data['eventName'].toString(), data: data['data'] as Data);
   │ └──────────────────────────────────────────────────────────────────────────^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/angel_websocket.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
angel_auth^2.0.0-alpha2.1.5+12.1.5+1
angel_client^2.0.0-alpha2.0.22.0.2
angel_framework^2.0.0-rc.02.1.12.1.1
angel_http_exception^1.0.01.1.01.1.0
http>=0.11.0 <0.13.00.12.20.12.2
merge_map^1.0.01.0.21.0.2
meta^1.0.01.2.21.2.2
stream_channel^2.0.02.0.02.0.0
web_socket_channel^1.0.01.1.01.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
angel_route-3.1.0+13.1.0+1
async-2.4.22.4.2
charcode-1.1.31.1.3
code_buffer-1.0.11.0.1
collection-1.14.131.14.13
combinator-1.1.01.1.0
convert-2.1.12.1.1
crypto-2.1.52.1.5
dart2_constant-1.0.2+dart21.0.2+dart2
file-5.2.15.2.1
http2-1.0.01.0.0
http_parser-3.1.43.1.4
http_server-0.9.8+30.9.8+3
intl-0.16.10.16.1
json_god-2.0.0-beta+31.0.1
matcher-0.12.90.12.9
mime-0.9.70.9.7
mock_request-1.0.71.0.7
path-1.7.01.7.0
quiver-2.1.32.1.3
quiver_hashcode-2.0.02.0.0
recase-2.0.13.0.0
source_span-1.7.01.7.0
stack_trace-1.9.51.9.5
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
tuple-1.0.31.0.3
typed_data-1.2.01.2.0
uuid-2.2.02.2.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs